Problems Autorouting pcb with Ver. 7.7.0

Questions relating to designing PCBs

Moderator: phalanx

Post Reply
KevinRoach
Posts: 2
Joined: Sat Oct 28, 2017 2:15 pm

Problems Autorouting pcb with Ver. 7.7.0

Post by KevinRoach » Sat Oct 28, 2017 2:40 pm

I am using version 7.7.0 and for some reason I cant get Auto router to work. I had some errors in my schematic and I fixed those. I watched a video on how the do the schematic and pcb layout and the router just doesn't come up and look the same.

I watched a video by Jeremy Blume for Element 14 but it was version 6.2 I think. So my auto route screen looked different but he just went through some of the tabs and settings and explanations and when he clicked ok or start you could see it do the auto route. I don't get that. I have attached the picture of my screen and what I get.


Thanks,
Kevin

Image

Image

Image

Image

Omgitskillah
Posts: 9
Joined: Tue Nov 28, 2017 11:33 am

Re: Problems Autorouting pcb with Ver. 7.7.0

Post by Omgitskillah » Tue Nov 28, 2017 12:24 pm

Hi KevinRoach ,

The Autoraouter in Eagle will not give you the same result if the components are layout out differently from the original. In 7.7, the autorouter may have been updated therefore would work better. Your DRU files may also be different from the original, this makes Eagle route the board so that it follows the new rules. (I assume it's Eagle you are using, you haven't said that explicitly)

I personally never trust the Autorouter to give me what I need, so I prefer doing it myself. You will find that doing it yourself will save you on space especially if you are trying to make very small boards.

I hope my answer helps.

Cheers

mattylad
Posts: 230
Joined: Sat Sep 25, 2010 3:49 pm

Re: Problems Autorouting pcb with Ver. 7.7.0

Post by mattylad » Sat Dec 02, 2017 4:23 pm

Take a piece of sticky tape and put it on your screen where the autorouter button is.
Then layout the board manually - it will be far better, have more consideration given to the tracking and you will have a better feeling of achievement.

Autorouters pah! next we will have self driving cars on the roads :)

will-notwill
Posts: 4
Joined: Mon Dec 04, 2017 8:50 am

Re: Problems Autorouting pcb with Ver. 7.7.0

Post by will-notwill » Wed Dec 20, 2017 6:17 am

mattylad wrote:
Sat Dec 02, 2017 4:23 pm
Autorouters pah! next we will have self driving cars on the roads :)
Oh yes we will. They promise them as soon as 2020 https://tranio.com/world/spotlight/self ... rket_5354/

mattylad
Posts: 230
Joined: Sat Sep 25, 2010 3:49 pm

Re: Problems Autorouting pcb with Ver. 7.7.0

Post by mattylad » Fri Dec 29, 2017 6:56 am

Yes and the same reply applies.
Put some tape over the auto drive button and take manual control yourself.

While autorouted boards may be electrically\spacing correct, according to your design rules -0 I have not met an autorouter yet that can consider current flow, EMC, nor the hundreds of other things that we consider in a millisecond while routing.
I used to have to run an autorouter over a PCB as part of a sales demo, the results while were correct to the rules were awful and I got to look like an idiot as the real idiot sat next to me tried to sell the software, I could tell the engineers sat opposite me were thinking that they would not use the autorouter.

Post Reply