SparkFun Forums 

Where electronics enthusiasts find answers.

Have questions about a SparkFun product or board? This is the place to be.
By olaf

I've got a Pro Micro 3.3V 8MHz and some problems talking to it. I'm using Linux, the Arduino IDE 1.0.5 (also tried 1.0, same effect) and downloaded the appropriate drivers from github so that I can select the Pro Micro 3.3V board. I've figured out how to trigger a reset, that I'd want to trigger the reset twice in short succession and I've even managed to upload a "sketch" that is happily verified by avrdude. After another reset or after timeout, the "programming device" disappears from the USB bus and all is good...

Except that the Pro Micro doesn't ever execute my sketch.

I've tried quite a few things, but none of them worked:
- I can't trigger a reset by setting the baudrate to 1200
- The device does not even show up as 1B4F:9204 or anything else at the USB bus
- Turning on lights as the first thing in hardware/arduino/cores/arduino/main.cpp doesn't do anything either...

I suspect that the thing is stuck somewhere between the bootloader and executing the sketch and my next idea would be to debug the bootloader by making the lights blink. That would require me to use a spare Arduino as some sort of ISP or so which I've never done before. I'd much rather hear "oh, make sure your sketch has this and that signature at this and that address" or "oh, make sure you have version x of the IDE and version y of the extra hardware configuration files"...

Any suggestions? What additional info do you need to help me?

By socrimspark
Hi Olaf,

I have the same problem here on LinuxMint 16 (64 bit). However, when I boot into my Windows 7 (64 bit) on the same machine, it works well on both, USB2 and USB3 connection with all of my pro micros.
Btw: It took me a while to figure out that I have to reset twice and chose "the other" serial port that shows up for 8 seconds.

I reall want to use my pro micros 3.3v under linux and I'm a little bit disappointed that Sparkfun does not address this problem in their pro micro guide. It's funny that they write that the installation under linux is so much easier than under windows. But they don't tell that the programming is only possible under Windows (and maybe MacOS).

If you or someone else figured out how to program the pro micro via USB under a debian based linux, please let me know.

Kind regard,
By socrimspark

in my case the modem-manager tried to talk to my pro micro after every reset, what confused avrdude to death.
I added a udev rule "/etc/udev/rules.d/77-mm-usb-device-blacklist-local.rules"
Code: Select all
ACTION!="add|change", GOTO="mm_usb_device_blacklist_local_end"
SUBSYSTEM!="usb", GOTO="mm_usb_device_blacklist_local_end"
ENV{DEVTYPE}!="usb_device",  GOTO="mm_usb_device_blacklist_local_end"

ATTRS{idVendor}=="1b4f" ATTRS{idProduct}=="9204", ENV{ID_MM_DEVICE_IGNORE}="1"
ATTRS{idVendor}=="1b4f" ATTRS{idProduct}=="9203", ENV{ID_MM_DEVICE_IGNORE}="1"

Since then, the arduino ide is able to upload every sketch I tried so far - even to the one that looked bricked... :-)
I would like Sparkfun to add a hint to the setup guide that the modem manager can disturb the communication if dmesg shows entries like
Code: Select all
modem-manager[1000]: <info>  (ttyACM0) opening serial port...
Kind regards,