SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
By paulvha
so your board is using the Ambiq uploader ... not the SVL.. the only disadvantage is the time it takes to load.. if you want you COULD add the SVL uploader It does NOT replace the Ambiq uploader, which is part of the ROM, but it makes uploading faster.. up to you!

Whenever you upload make sure the IDE monitor is CLOSED. It might display / pick-up feedback from the board that is mend for the uploader and as such uploading is failing.
By paulvha
it seems it is not getting a response from the board. Try to remove / reconnect the board and see what happens. You have the Ambiq uploader else it would have failed before, but also try with SVL
By paulvha
To be frank... I am running low of suggestions. The fact that it worked ONCE with the Ambiq uploader is important. At least we know that it worked / works.
Does the board LEDS still blink ?
Try reboot your Apple / PC maybe there is something else impacting/ hanging/ impacting the port. (that won't be the first time for me..)
Does this impact BOTH of your boards?
User avatar
Sadly, the onboard LEDs do not blink and both boards still have the same problem, even when rebooting and changing ports and cables.

Thanks, APS
By paulvha
I am calling it a day .... it is late here (Amsterdam/ Netherlands).. maybe more / better thoughts tomorrow... still very weird.. Maybe give it another try with SVL.. who knows..
User avatar
No worries, thanks for all the help, nice to see other people living in Europe post on the forum as I am in London and this isn’t the most popular hobby here! Till tomorrow. Good evening.
By paulvha
I am running low on ideas.
1. Back to basics: double-check/reinstall the drivers, the setup of the power supply, and the correct board etc. etc. This issue is caused by something fundamental/basic.
1. There is another post that is working on the LORA EXPLORABLE with other problems, but maybe that person is better help than me
2. Try to install the Sparkfun bootloader. you can get that from
3. Maybe you have bad luck and 2 boards and should return them.
User avatar
I think you are right, I just connected my Qwiic devices to an old Arduino nano 33 BLE and it worked with no problems, the only reason I bought the Lora ExpLoRaBLE board was for LoRa, but I think I am better off returning my boards and using an external radio with my Arduino as I am on a tight schedule, many thanks for all the help you have given me thus far and goodbye for now.

 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum