SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
User avatar
By BarryAllen
#229409
Hello,

I'm having problems getting the Qwiic LED Stick up and running with Artemis running Arduino. The LED Stick works great with Python on Raspberry Pi, Adafruit QTPY Samd21, LoRa Pro RF, ESP32 boards but fails with Artemis nano, Artemis ATP, and the Apollo3 LoRa Thing Plus. It appears to be a communication problem but example 10 from the LED Stick was able to show many available i2c addresses including default (0x23). Just curious if anyone has some ideas as I'm kinda stuck. Thanks.
User avatar
By PaulZC
#229410
Hi @BarryAllen,

I guess you are using v2.1.1 of the Apollo3 (Artemis) boards in Arduino? Please try v2.1.0 and see if that makes a difference.

The ATtiny on the LED Stick will use I2C clock stretching, and the Artemis does not enjoy that - especially in v2.1.1.

Best wishes,
Paul
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]