SparkFun Forums 

Where electronics enthusiasts find answers.

Hardware or product specific questions are best asked here.
User avatar
By jiggermole
#214276
Got a 64gb sd card from sparkfun and its formatted exFAT tried reformatting several times but the Artemis OpenLog says "SD init failed. Do you have the correct board selected in Arduino? Is card present? Formatted?" Not sure where to start troubleshooting this problem.
User avatar
By sparky
#214289
Hi,

Thanks for trying out OLA! Please update the firmware on your unit. v1.0 had support for cards up to 32GB. v1.1 rolled out exFAT support for cards up to 512GB. Please download the binary from either the product page (documents tab) or from the repo.

Binary: https://github.com/sparkfun/OpenLog_Art ... is-v11.bin
Update firmware tool: https://github.com/sparkfun/Artemis-Firmware-Upload-GUI

Let us know if you run into problems by opening an issue on the appropriate repo.

Cheers,
-Nathan
User avatar
By jiggermole
#214420
yep, I did that shortly after posting but I couldn't update the post for some reason. The card works now. Have other issues but those don't belong here. Thanks.
User avatar
By slowrider.sf
#215544
Just setup the OLA with a BME280 module. When I configure the terminal logging any slower than 1hz, I get an error: SD init failed. Is card present? Formatted?

I thought it might have to do with the the Qwiic bus powering down between readings, but the issue persists when I turn off that option.

Any ideas are appreciated. And if the answer is upgrading the OLA firmware, is there a method to do this from MacOS?
User avatar
By zapda
#215572
I'm also having a problem hooking the SD card up to the Artemis Nano. Not sure I've got the pinouts right - this is what's in the CardInfo example, which I've triple checked. I'm getting "Initializing SD card...initialization failed" etc etc.
Code: Select all
** MOSI - pin 11 on Arduino Uno/Duemilanove/Diecimila
 ** MISO - pin 12 on Arduino Uno/Duemilanove/Diecimila
 ** CLK - pin 13 on Arduino Uno/Duemilanove/Diecimila
 ** CS - depends on your SD card shield or module.
 		Pin 4 used here for consistency with other Arduino examples
I tried wading through the schematic but it was tricky to sort out what Apollo3 pinouts map to these. Thanks!
User avatar
By liquid.soulder
#215620
slowrider: I'm not very familiar with the OLA, but I do not expect that the SD power would be directly tied to the Qwiic power lines. Nate worked pretty hard on the OLA to enable independent power-shutdown of various components (sensors, SD card?). As you can tell the uploader tool repo (link provided by nate above) only seems to have a .exe executable. However I think that the tool is written entirely in Python (perhaps using tkiner?) You may be able to run the script using Python (2 or 3?) directly or it may be possible to generate mac / linux executables using pyinstaller.

I will also look into doing this, and if it works out I can post the executables in that repo.
User avatar
By sparky
#215625
@slowrider - Thanks for trying out OLA! Please consider opening an issue on the OLA firmware repo so we can track it. I suspect the BME (rather than BMP280) could be an issue. The autodetect system is somewhat expecting the BMP.

Wrt the SD card not cycling correctly, it's hard to say. Please file the issue on the repo. We need to know what firmware version you're using.

Wrt to Mac upgrade path - I'll respond over on the issue: https://github.com/sparkfun/Artemis-Fir ... I/issues/1
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]