SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Programmers category & general programming devices should be posted in this forum.
#208055
Hello
I just acquired two SparkFun Thing Plus - XBee3 Micro.
It is well operational, but on one the micropython loop program, it is not giving me back my hand.
XCTU does not work with the Xbee Recovery feature, even reducing port transfer speeds or activating the Reset.

How can I reset it?

Thank you
#208081
Hi paragliding.tech,

Sorry to hear you are having trouble getting your XBee3 Thing Plus back to full functionality. Just to try and get a better idea of where it got stuck and what you have tried to recover it, can you elaborate on what loop it got stuck on and what error XCTU is returning when you try and restore it? For example, are you testing with Experiment 1 from the Hookup Guide or some other MicroPython code?
#208577
Hi TS-Mark

Thank you for your reply.
Sorry for not answering you faster.

It's on the blinky program. The LED remains illuminated in blue.
I would like to resume my hand.

Until now, I was on XBEE-Arduino. I'm looking for PyCharm.

cordially

Jean Philippe
User avatar
By TS-Mark
#208689
Hi again Jean Philippe,

Is the XBee Thing Plus showing up as anything in your Device Manager? It might be showing up under "Universal Serial Bus Controllers" or possibly as an unrecognized device in your "Ports" menu. Try re-installing the CP2104 USB driver found here and see if that allows you to see the board again in your device manager and if so, then try going back to XCTU and searching for devices.