SparkFun Forums 

Where electronics enthusiasts find answers.

User avatar
By Stephane_P
#207662
Hi!

I'm using a GPS-RTK2 Board - ZED-F9P (Qwiic) since a few months, and it was working correctly. But since today, every time I power it up, the led "power" "pps" and "fence" stay on and I don't receive any data from the uart. When I connect it with Usb, Windows says "unknown peripheral, Device Descriptor Request Failed"
I can get some information if I send 0x55 0x55 to it (via uart1) and connect it to u-center, and I can flash it successfuly, but after a power cycle, I encouter the same problem.
The F9P seems to be always in safeboot even though the safe pin isn't connected to GND. There is no internal shortcut between safeboot and gnd.
A visual inspection shows nothing strange.

Is there a way to "unbrick" it ?
#207676
Hi Stephane.

Have you tried connecting it to an Arduino via I2C and running the FactoryDefault_I2C sketch? That should bring the GPS back to life. Failing that, there's a 'Default Config' button in U-Center you might try that should set the GPS back to factory defaults over USB.
#207685
Hi TS-Chris!

I can run the FactoryDefault_I2C sketch successfuly, but I still don't receive any byte when I run Example14_DebugOutput sketch.
Same behaviour after I connect the reset pin to GND.
I can't connect the F9P over USB anymore (Device Descriptor Request Failed)

When I connect the F9P with an uart/usb adapter, then connect the F9P to U-Center, I can get some informations like these :
Software version: ROM BOOT 1.02 (a11814)
Hardware version: 00190000
Extensions: PROTVER=26.00 - MOD=ZED-F9P

There are some informations available on this screenshot, safeboot is always active:
You do not have the required permissions to view the files attached to this post.