SparkFun Forums 

Where electronics enthusiasts find answers.

User avatar
By ravikant
#203198
When I run "make bootload" I see the error below. I tried the suggestions in https://stackoverflow.com/questions/554 ... r-problems. But no luck. Did anyone get this working on Mac successfully?

../../../../../tools/apollo3_scripts/create_cust_wireupdate_blob.py --load-address 0x20000 --bin bin/main_nonsecure_ota.bin -i 6 -o bin/main_nonsecure_wire --options 0x1
Header Size = 0x60
app_size 0x468c ( 18060 )
Writing to file bin/main_nonsecure_wire.bin
Image from 0x0 to 0x468c will be loaded at 0x20000
../../../bsp/tools/uart_wired_update_sparkfun.py -b 921600 /dev/tty.wchusbserial1420 -r 1 -f bin/main_nonsecure_wire.bin -i 6
Connecting with Corvette over serial port /dev/tty.wchusbserial1420...
Sending Hello.
response len = 0
No response for command 0x00000000
Traceback (most recent call last):
File "../../../bsp/tools/uart_wired_update_sparkfun.py", line 342, in <module>
main()
File "../../../bsp/tools/uart_wired_update_sparkfun.py", line 42, in main
connect_device(ser)
File "../../../bsp/tools/uart_wired_update_sparkfun.py", line 61, in connect_device
response = send_command(hello, 88, ser)
File "../../../bsp/tools/uart_wired_update_sparkfun.py", line 239, in send_command
raise NoResponseError
__main__.NoResponseError
make: *** [bootload] Error 1