SparkFun Forums 

Where electronics enthusiasts find answers.

User avatar
By Undead8
I have a Redboard Turbo DEV-14812

I tested a few things such as blinking LED and playing a song using the MP3 Qwiic Trigger and it worked fine.

However, now windows does not recognize the USB device when I plug the board. The board is no longer detected so I cannot upload code. How can I fix this?

Also, the charge LED is always on. The hookup guide says it should only be on when a battery is plugged and charging. I did not plug any battery.

Before the USB failed, I noticed that there was nothing showing in the serial monitor, despite using code provided by sparkplug and replacing Serial by SerialUSB as provided in the hookup guide.

Any idea how I can fix the USB not recognized thing?
User avatar
By TS-John
We have seen some issues with the SAMD21 drivers on certain Windows Operating Systems recently. We believe that a Windows update may have broke something.

What version of Windows are you running currently? Have you tried a different computer with a different OS?
User avatar
By TS-Chris
Also, the charge LED doesn't mean anything when you don't have a battery attached. Sometimes it might be on, sometimes it might be off. It could even blink or flicker but this means nothing without a battery.

If you DO have a battery attached, the LED is on while charging and off when the battery is fully charged.
User avatar
By Undead8
Thanks for the reply.

Windows 10 version: 1803 (17134.648)

I also tried on a linux computer (debian distro) and it simply did not show up at all. I will try again tonight.

I'm starting to suspect I have a defective board.

EDIT: I would like to add that the board worked for maybe 5 minutes of intermittent use before it was no longer recognized by windows. I did not reboot in the meantime so there was no new version of windows in that time frame.
User avatar
By Undead8
Yes, double-clicking made it work. I found the problem and it's 100% me.

The redboard turbo is connected to a Qwiic MP3 Trigger. I used the example code found here: ... aySong.ino

However, while testing, I removed this part, which caused the board to crash and stop being detected:
Code: Select all
  //Check to see if Qwiic MP3 is present on the bus
  if (mp3.begin() == false)
    Serial.println("Qwiic MP3 failed to respond. Please check wiring and possibly the I2C address. Freezing...");
    while (1);
My understanding is that the the Qwiic MP3 takes about 1500ms to boot. By removing this, I tried to play a song without waiting for the Qwiic MP3 to boot, so it crashed.

Double-clicking the reset button resets the code, so my computer could detect the board again.

Thanks for the help.

EDIT: Or perhaps
Code: Select all
is required to boot the Qwiic MP3 trigger? Anyways, it works with that code and doesn't without.