SparkFun Forums 

Where electronics enthusiasts find answers.

By jwells
I bought a couple of the ESP32 development boards. I'm using the Arduino IDE with the ESP32 plugin, and I'm unable to upload my code. I've tried it on two separate computers and on both boards. The strange thing is that for my first attempt I successfully uploaded a blinky program, but then when I went to use my "real" code, it won't upload to either board

Details: I have the latest Arduino IDE 1.8.8. Windows appears to successfully install the FT231X drivers. My micro-usb cable works for other devices (card reader) so I don't think it's a bad cable. Pretty sure I've tried it in USB 3.0 and older ports. Tried it on a WIndows 10 and a WIndows 7 computer.

Below is my error message. I've tried picking different ports and upload speeds. I'm out of ideas.

Arduino: 1.8.8 (Windows 7), Board: "ESP32 Dev Module, Disabled, Default, 240MHz (WiFi/BT), QIO, 80MHz, 4MB (32Mb), 512000, None"

Build options changed, rebuilding all
Sketch uses 251740 bytes (19%) of program storage space. Maximum is 1310720 bytes.
Global variables use 15028 bytes (4%) of dynamic memory, leaving 312652 bytes for local variables. Maximum is 327680 bytes. v2.6-beta1
Serial port COM8

A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header
A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Anybody got any ideas?

By jwells
Paulvha: You got it! I stumbled onto this randomly a few minutes ago, but I appreciate your response. You have to press and hold Pin 0 to get it to "flash." That might be something that Sparkfun should boldly put into their hookup guide.
By paulvha
you have to press the button when the "connecting..." appears on the screen. Once it starts uploading you can release it. Also make sure your serial monitor is closed, otherwise you uploading will fail often.