SparkFun Forums 

Where electronics enthusiasts find answers.

All things pertaining to wireless and RF links
#200947
I'm having several problems with my RN42 Bluetooth Module.

The inquiry command: I,<value> is not working. Everytime I search for available bluetooth devices, the terminal/putty (I tried both on different machines) outputs available devices and then gets stuck. I'm not able to input any commands, and the green indicator light on the module immediately turns off when I run the inquiry command. Connecting with C<remote address> without Inquiry also doesn't work.

This all happened when I did my first pairing through bluetooth. I decided to try to bypass the problem by controlling the module through serial input on a breadboard. However, I can't get the bluetooth module to output anything back to me despite entering command mode and turning on ECHO.

Other minor issues is that whenever I close putty/terminal without shutting off command mode, the bluetooth module is stuck in command mode.

Any ideas? Thanks