SparkFun Forums 

Where electronics enthusiasts find answers.

Have questions about a SparkFun product or board? This is the place to be.
By spamiam
I am trying to use the DEV-13743 "Shifting uSD" micro SD card adapter board. I have it hooked up to my Arduino Mega2560 and the Arduino SD/FAT module can't find a card in the board.

When I use the same micro SD card in a full size SD adapter in an Adafruit SD/datalogger shield, it works fine. I do switch the CS pin setting from 10 on the shield to 53 for the micro SD card hookups. The Adafruit shield is able to read and write to the SD no problem with the exact same program.

I put the MISO/MOSI/SCK and CS pins on a scope as I tried to access the micro SD card. I got activity that seemed normal to me. I tried reversing the DI and DO pins and that didn't make it work. I tried using pin 10 for the CS signal (set up appropriately in the program, similar to the Adafruit board) and the card was still not recognized by the program.

I have Vcc and ground hooked up to +5 and gnd respectively on the micro SD card PCB.

SO.... what am I doing wrong?

Well, I got it working. It would appear to be a problem with the ribbon cable from the Arduino mega to a PCB which among other things has a connector for the MOSI/MISO/CS/SCK signals.

I connected the SD crd directly to a Mega and it worked. I then substituted a new and shorter ribbon cable and it works properly.

Maybe the original ribbon cable was too long? It was a re-purposed computer IDE cable.