SparkFun Forums 

Where electronics enthusiasts find answers.

Have questions about a SparkFun product or board? This is the place to be.
By Ducksy
#197115
Good Day I am trying to load the Sparkfun Weather station compile, I am having no luck.
I keep coming up with.



Arduino: 1.8.5 (Windows 10), Board: "Arduino/Genuino Uno"

C:\Users\Ducksu\AppData\Local\Temp\arduino_modified_sketch_905108\sketch_dec05a.ino:30:110: fatal error: SparkFunMPL3115A2.h: No such file or directory

#include "SparkFunMPL3115A2.h" //Pressure sensor - Search "SparkFun MPL3115" and install from Library Manager

^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.



I have no experience In programming , just wish to get my Sparkfun Weather Station running.

Yours Hopefully David.
By LarryManalo
#197117
Hey David,

I'm also a relative noob, but did you download the MPL3115A2 library and add it to your Libraries folder under Arduino?

The library can be found at: https://github.com/sparkfun/MPL3115A2_B ... es/Arduino

And if you installed Arduino using defaults, the folder for libraries (if running on Windows 10) should be something like:
This PC > Local Disk (C:) > Program Files (x86) > Arduino > libraries

Let me know if you have any further questions, and I'll get back to you when possible!

Cheers,
Larry
By Omgitskillah
#197119
Hi David,

I think the MPL3115 library was not installed well or not installed.
Go to https://github.com/sparkfun/MPL3115A2_B ... es/Arduino and download the repo as a zip file.
Open arduino IDE, go to include, then mamage libraries, then choose add zip files.
Navigate to where the zip files were saved and select the MPL library zip.

Arduino should then automatically install the library for you.

Try to recompile your code after this.

All the best.
By paulvha
#197820
Make sure to install the Sparkfun versions of the libraries. If you installed the correct one, the next compile will give you a simular error but then it refers to SparkFun_Si7021_Breakout_Library.h. You will also need to install the SparkFun_Si7021 library... you can follow the steps indicated by David or do:
sketch, include library, manage libraries. type in the search bar: Sparkfun si7021. You will see the Sparkfun version, click info and install. (same procedure can be followed for: Sparkfun MPL3115). After it compiles without error (if nothing else changed).