Pro Micro on windows 10 driver not starting code 10

Have questions about a SparkFun product or board? This is the place to be.

Moderators: phalanx, TS-Tim

Post Reply
jnivard
Posts: 6
Joined: Tue Sep 26, 2017 12:26 pm

Pro Micro on windows 10 driver not starting code 10

Post by jnivard » Wed Sep 27, 2017 5:22 am

I have 2 Pro micro boards and it seems impossible to get them working
I use windows 10 x64 bits version

In the device manager, the driver it is marked with a ! sign. I have loaded both drivers (normal and boot) and both have the same problem

I dit reset the windows signature controle by the and windows is starting in test mode.
As result of that the ! is disappearing in the device manager
But the com ports are not showing up in the Arduino IDE and I am not able to upload a scetch

I followed the boot procedure, but that seems to make no difference at all

Who has a sollution

jnivard
Posts: 6
Joined: Tue Sep 26, 2017 12:26 pm

Re: Pro Micro on windows 10 driver not starting code 10

Post by jnivard » Sat Oct 21, 2017 9:46 am

I have now tryed two differend windows 10 PC's and used 3 differend
pro micro boards, one brand new from sparkfun. It is inposible to get is working
I recieve the code 10 from the windows device manager.

When I run the microsoft devender the defender is removing te sparkfun device driver

Who can help?

jnivard
Posts: 6
Joined: Tue Sep 26, 2017 12:26 pm

Re: Pro Micro on windows 10 driver not starting code 10

Post by jnivard » Sun Oct 22, 2017 5:15 am

Hai

I am test and added a FTDI device driver and that is working
The SparkFun pro micro is listed but has a stop code 10
I include 3 screen images of the device list with all the details

I used (2 different window 10 machines and 3 different new Pro Micro boards

Who can help!
Attachments
Schermafdruk 2017-10-22 13.43.45.png
Schermafdruk 2017-10-22 13.54.26.png
Schermafdruk 2017-10-22 13.54.46.png

jnivard
Posts: 6
Joined: Tue Sep 26, 2017 12:26 pm

Re: Pro Micro on windows 10 driver not starting code 10

Post by jnivard » Sun Nov 05, 2017 1:29 am

I am adding the screen shot the report from windows defender
Schermafdruk 2017-11-05 09.25.15.png

jnivard
Posts: 6
Joined: Tue Sep 26, 2017 12:26 pm

Re: Pro Micro on windows 10 driver not starting code 10

Post by jnivard » Sun Nov 05, 2017 9:15 am

I have found the problem,

I did download the file from GitHUb and what I did discover that there is a installation.exe.
But the dpinst-x86 refusing to instal on a 64 but intel machine. It is only for a 32 bit machine.
I did by accident did instal the dpinst-amd64.exe, But that is for a amd processor not a 64 bit intel processor.
It did instal but whit the stop code 10

Do you have a version for the 64 bit intel machine. Nowadays all processors are 64 bits

Please some help

John Nivard

Post Reply