SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By charlievictor102
#85849
I was having trouble getting binary message mode to work on my Venus634FLPx attached to a HCS08 eval board. So I got the LVTTL to USB converter. I can talk to the Venus using the GPS Viewer app. But when I click on the "Binary" button nothing happens and the NMEA output stops. This is kind of what I saw using my HCS08 board. The Venus seems to NACK when I do stuff like click on the "Query BinaryMsg Interval".

Anyone know how to get binary mode to work?

The version info is as follows:
SkyTraq Kernel Version 1.4.23
SkyTraq Version 1.10.23
SkyTraq Revision 2009.2.10

Curt
By tz
#86558
Binary and NMEA are mutually exclusive.

You shouldn't be getting NAKs if the packet format is correct, but that might take some doing. I can upload AGPS data so I would suggest you look for other programs which support the chip - all of those functions are in binary.
By charlievictor102
#86713
SkyTraq tech support says that this part doesn't support binary mode. I got it to work (10Hz) using NMEA messages. I configured the board using the "GPS Viewer" app.
By gussy
#86993
Even though SkyTraq say it doesn't support it, there is still this document: http://www.sparkfun.com/datasheets/GPS/ ... v1.4.8.pdf which suggests that it does.

It could be that it just isn't fully supported yet. Has anyone here actually got binary to work?
By tz
#91082
Binary may be disabled, but if it is not, this project used the binary streams from similar modules. Also note you may need to request or set a rate or something in binary mode before it will start sending data.

http://gpspp.sakura.ne.jp/rtklib/rtklib.htm
By jeanseb
#91465
gussy wrote:Even though SkyTraq say it doesn't support it, there is still this document: http://www.sparkfun.com/datasheets/GPS/ ... v1.4.8.pdf which suggests that it does.

It could be that it just isn't fully supported yet. Has anyone here actually got binary to work?
With the latest firmware version I am able to talk in binary mode to the GPS unit.

However, the endianess seems opposite to what the documentation says. Also, while the documentation says the unit will only send one ACK, following a command the unit will send back 2 NACKs.
By hdkippa
#137648
My Venus is returning 2 ACKs for each command sent too.

For example, sending the "switch to binary mode" command 0x09 returns 2 ACK sequences. First ACK is for command 0x00. There is no command 0x00:
Code: Select all
0xa0 0xa1 0x00 0x02 0x83 0x00 0x83 0x0d  0x0a
immediately followed by another (correct) ACK packet:
Code: Select all
0xa0 0xa1 0x00 0x02 0x83 0x09 0x8a 0x0d 0x0a
No matter what binary command I send
- there are always 2 ACKs returned;
- the first ACK is always for command 0x00, as shown above;
- the second ACK is correct as specified in the manual (such as it is) for the command sent to Venus.

Perhaps this will get fixed in later firmware releases. Silly for a bug like this to get released, unless there is some reason for it, though I can't really think of one.
By Matz
#141517
I asked Skytraq support about the two ACKs a while ago. This is what they responded:
"For historic reason, it sends out first ACK with 0x00 ID to flush recipient buffer, please wait till ACK with correct ID is received for proper acknowledge hand-shake."
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]