SparkFun Forums 

Where electronics enthusiasts find answers.

All things pertaining to wireless and RF links
By johnty
#75217
I bought a bluesmirf silver about a month ago.

This is what I have working with it:

-FTDI usb-serial adapter. Running two terminal programs, one connecting to the USB end and another via bluetooth, I was able to send data between the two terminals. So RX/TX on it is working.

-Arduino Mini - have some sample code that pushes data through the serial. I can connect to it via bluetooth and see the data coming out the other end.

So far so good...

BUT... because its default to 9600, and I need it to run faster (at 115200), I have to go into config mode. And it simply does not work. I've tried to send the "$$$" locally (via the usb-serial adapter), as well as through bluetooth ... but nothing works (no response). The RX/TX on the usb-serial adapter lights up so data is obviously been pushed through the bluetooth connection, but the bluetooth module itself doesn't seem to be responding to the command. I believe the default time limit to get into config mode is within 60 seconds... tried to do it as soon as I can after power up and it still does not work.

Anyone else experience this problem, or have any suggestions?

Thanks in advance,

Johnty
By riden
#75218
Isn't the escape sequence "+++" and not "$$$"?
By johnty
#75300
awesome! the "+++" worked. wish the manuals/documentation could be more consistent.

a lot of the other commands don't seem to work (i.e. anything other than AT+xxx"). maybe i'm reading the RN manual in the wrong context? in fact, i'm beginning to think that I could probably evoke the AT commands without actually using "+++" to begin with... will play around with it a little more and see.
By JoeStrout
#75986
Neither "$$$" (the sequence specified in the RN docs provided by SparkFun on the BlueSMIRF page) nor "+++" (the sequence suggested here) works for me.

In addition, I can't see any way to reset a BlueSMIRF to the factory defaults. Unless I'm misreading the schematic, PIO4 (the reset line according to the RN docs) is tied permanently to ground. Did SparkFun really design a configurable board with no way to reset to defaults?!?

(Of course, the same manual also says that "$$$" is the sequence for dropping into config mode, so who knows...)
By johnty
#76001
does AT work for you? And are you trying through a local connection (e.g. usb-serial to bt dongle) or remote via bluetooth?
By JoeStrout
#76035
johnty wrote:does AT work for you? And are you trying through a local connection (e.g. usb-serial to bt dongle) or remote via bluetooth?
No, AT does nothing, nor do any of the AT commands I attempted. This was via bluetooth — I'm not set up at the moment to try a direct connection, but I'll have to do that sooner or later. From the manual, I wouldn't expect that to matter as long as I try my "+++" or "$$$" within the first 60 seconds. But who knows.

However, the device is connected and working — I'm able to pass commands on through to the Pololu dual serial motor controller, so fortunately, the current baud rate appears to be 9600 (which is what this motor controller needs). But I'll be in trouble if I need to talk to some other device, such as the RoboBuilder servos (which speak at 115200 baud). Unless, of course, I'm able to configure the BlueSMIRF via direct connection...
#156683
I've dug this device out again to use it for a new project, and still no luck. That it works fine at 9600 baud out of the box... but now I'm trying to reconfigure it to a different baud rate, and I can't get it to work.

There is certainly a lot of confusion about what radio, and therefore what command set, is in these units. Perhaps they changed at some point. The link on https://www.sparkfun.com/products/582 goes to a Roving Networks module that says the command-mode string is $$$, but the text of the same page says it's a Blue Radios (not Roving Networks) radio, and their reference (http://www.sparkfun.com/datasheets/RF/B ... .1.4.0.pdf) clearly says it should be +++.

For me, over a direct connection (USB-BUB wired up with TX to RX and RX to TX), "+++" works: I get back "OK" and I can then type "AT" and get "OK" back in response. But any other AT command at all returns "ERROR". I've tried "ATSI,2" and "ATMD" and "ATURST" and "ATVER,ver1" and virtually every other sample command I can find, all without quotes and followed by a carriage return of course. They all result in "ERROR".

Over a Bluetooth (rather than wired) connection, neither +++ nor $$$ have any effect at all.

Meanwhile, the LEDs on the BlueSMiRF-v2 itself show one solid red, the other dark. I don't know what this means, because that doesn't seem to be documented anywhere. I think it just means "power good, no Bluetooth connection."

Has anyone got AT commands to actually work with this thing? Any idea why they might not work for me?