SparkFun Forums 

Where electronics enthusiasts find answers.

All things pertaining to wireless and RF links
By tintenfisch
#55430
Hi,

I just purchased two XBee 2.5 radios and one Sparkfun XBee Explorer USB.

I wired one radio to my Arduino board and connected the other one to my Mac computer. I wasn't able to configure the two devices to talk.. I tried many different configurations with AT commands and all of a sudden the radio connected to the computer stopped working.

It's no longer responding to the +++ command.. I assume that I corrupted the firmware somehow.

Since I only have a Mac I haven't tried out the "windows only" software from digi yet.. hopefully I can try it out at work tomorrow.

Any ideas.. ? Can I save it?

Thanks!

/Jonathan
By tintenfisch
#55449
I managed to get the CTU software running in Windows XP under WM Ware Fusion on my Mac.
There was a handy restore function that did the trick :)

So now I'm back at config mayhem!

/J
By ceibawx
#57003
Hi,

I met similar problem of xbee.
It doesn't communicate each other. I think reset is needed.
But now I have only two xbee802.15.4. I did not buy program board.
Do you have any methods?
And would you like to tell me how to reset xbee?
What's handy reset?


Your reply is appreciated.


Regards,
Xing
By dstirk@hughes.net
#58361
So, Looks like some of you have had the same problem as I have.... Downloading software and getting "bricked boards". After I receive my development board (RS232), how do I restore factory settings ?
Thanks.
By stevech
#58432
There is a documented non-obvious combination of buttons to push. I'll try to remember where it is among Digi's user manuals
By jodie
#61368
Buttons? I seem to have a distinct lack of anything resembling a button on my Series 2 radios...

I had it responding fine in AT command mode. I wrote a PAN to it using the Digi app, and then ... Nothing. Error from the Digi app (X-CTU) and now it's not responding to AT commands anymore.

I don't have an explorer board - I'm just talking to it from a Sparkfun level converter and a serial port under Windows - but it worked fine before. Are there some pins that some button shorts or ... ? I'd really like to have not bricked a radio. I'm up against a design deadline...

[edit] Ok - I put a pushbutton to ground on the RST pin. X-CTU was able to detect my hitting the reset switch on a restore. I'm downloading new software - but I'm not sure what profile it should even be... Sigh.

[edit] I put my good matching XBee on and did a read from it. XB24-B Zigbee Router/End Device AT Version 1220.

So I put the bricked one back on


Restore
Unable to communicate with modem
Pull RST low for a couple seconds, and the Info window disappears just like it says it will.
I see data go to and from the device a few times (RX/TX lights on level matcher flash) X-CTU reports "Resetting AT Commands..."

Comes back a bit later and says "Unable to find configuration file for modem (firmware version õ). Use 'Download new versions" button to check the web for newer versions

Gobbledy-gook for a version number can't be good. I'm at a loss...

[edit] Tried a "always update firmware" and it got stuck in an "update summary" loop. I finally got tired of clicking "ok" after the 341 time, and killed it, and rebooted. No data was going to or from the modem...

TIA for any advice!

--- Jodie
By jodie
#61375
I switched X-CTU to API mode under PC Settings and was able to write the AT mode software to the device, reset and there I was.

Now I just need to figure out how to re-insert all the hair I pulled-out...
By brikk
#65592
I experienced a similar problem. I got an Xbee module with firmware 1084 but it wasn't in my firmware list so I decided to flash the latest. I succeeded flashing but I still couldn't read the firmware (it still told me it was an unknown firmware), so I tried the 1083 version which also was in my list. The flash went fine but after that it stopped responding completely. I was able to test/query by checking the Enable API box, and got a dialog box with some jibberish in it. The green LED on my USB board was blinking rapidly as well.

I also got the dialog box which tells me to press reset and then the dialog should close within 10 seconds, but that didn't do any good. However, by selecting the latest firmware, holding the reset button down while pressing Write and not releasing the reset button on the board until the status bar progress changed I got to the point where the firmware was flashed without problems.

Maybe that trick can help someone else too :)
By stevech
#65649
I don't think you can "brick" an XBee series 1 (don't know about series 2).

I've abused them a lot and using Digi/Maxstream's procedures with XCTU and their dev kit motherboard, always been able to reinstall firmware.
By aludra_55
#65866
I got the same problem. I've tried resetting, etc but it still doesn't respond to +++ AT code. I've tried different baud rate and even check and unchecked the API button. I'm at a lost. I posted the same subject few days ago.
By stevech
#65881
if you are stumped, send me the XBee module and I'll try to reset it.

PM
By isnoop
#66093
Sad day. Same problem here. My 3 XBees were responsive (they'd send a period back if I sent them +++), but now I get nothing either through the comm port directly or with X-CTU.
By fenichel
#67146
I have 3 XBeePro modules with the same problem. I was trying to configure them for API operation and somehow got them into a state in which XCTU can't communicate with them at any baud rate or handshake mode. Is there a known fix yet?
By aludra_55
#67266
I got my 2 XBee Pro modules restored to its factory settings (thanks Steve!). Both could respond to AT commands but still not able to transmit the actual data. I would send a "counting" number (ex: 1, 2, 3, 4...) but it would display garbage data at the terminal. Both modules appear to be communicating very fast but the problem of garbage data remains. Anybody solved this problem yet?
By stevech
#67335
tell us the specifics on your configuration - what firmware, AT settings, etc.

And if you can get one of Digi's demos to run.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]