SparkFun Forums 

Where electronics enthusiasts find answers.

All things pertaining to wireless and RF links
By xetibom
Hi There,

I have been using Xbee 1 for a short time. I purchased a few Xbee 2.5 versions. They both worked well using X-CTU.

I'm not sure what I did next. Being somewhat distracted I think I may have attempted to download the ZNET 2.5 ROUTER/END device digitial IO function set. X-CTU attempted the download but failed. The XBee no longer longer communicates with X-CTU (or anything else)

Is there some way to do a factory reset without being able to communicate with the device?

By stevech
I've not used series 2, but maybe you changed the default baud rate and you need to change that in XCTU?

I recall that with series 1, there was a certain squence of button pushes to reset to factory defaults.
By xetibom
Unfortunately, no baud rate appears to work. I have attempted everything from 1200 to 115200.

In an attempt to figure out what I actually did I tried the same thing wih a second 2.5 series Xbee and it ended up in the same condition. I cannot communicate with either.

A factory reset would appear to be the only solution but I have not run across any way to do this aside from using AT commands - which no longer work.
By Interdit

I tried the same profile and now I have 3 modules defect. Hoping to find a default factory option.

Failed to enter command mode
Unable to read Version (ATVR)
Detected baud rate difference.
Make sure PC and modem baud rate is set correctly
Read parameters..Failed.

Led 1 and 3 is on, power on and RX always on...

Did you find a solution ?

By Interdit
I could reset my xbee modules like this on by RS232 board:

Check 9600 – hardware – 8 – none – 1 – No baud change checked
Choose your profile, then press reset at the same time click on write then wait until the first RSSI light then release the reset button and wait one or two minutes.

In fact these profiles disable the UART modem, so it's normal that we can not communicate with it afterwards, but what's not logic, it's to get errors.

By ceibawx
How did you do finally?
Did you do it?
Now I have no Program board, and my xbee doesn't communicate, so Should I buy a program board if I want to make a factory restore?

Expect your reply.

By Interdit
Yes you need a dev board RS232 to restore it.
By artcar12
You can do it without a dev board.

It is possible when using the USB board. You just have to go about it in a different manner.
1. Take the module out of the interface board.
2. Connect the interface board to the computer.
3. Open X-CTU
4. Go to "Modem Configuration"
5. Put a check in the "Always update firmware" box
6. Select proper modem from drop down menu,
7. Select proper function set and firmware version
from drop down menus.
8. Click on the "Write" button. After a few seconds of
trying to read the modem, you will get an Info box
that says Action Needed. At this point, CAREFULLY
insert the module into the interface board.
9. You may get the info box again a short while after,
just use the reset button on the interface board.

This should get you back up and running.

It can take a couple of tries but it worked for me.

If you just have a breakout board make sure you hook up the Xbee like this: ... grade.html

It won't work with just just Dout and Din connected. Otherwise follow the instructions above.

I took this info from this post:
By heathkit
Ok, so I just had this problem, having just now stupidly flashed my XBee with an "API" firmware instead of AT.

You can totally solve this in seconds. Just write the new firmware with X-CTU. It'll fail, and you'll get a dialog box asking you to reset the board. The sparkfun breakoutboard doesn't seem to pull out the ~RESET signal, but it's on pin 5. Just get a little jumper wire and short pin 5 on the module to pin 10 (pin 1 is the upper left, with the angled side up, pin 10 is the lower left) for a few seconds. When you let go, flashing will continue.
By rmcl
Thanks heathkit! That worked for me.
By parki

I've done this, and resetting the board definitely does something, but the XBee controller (Series 2) now won't accept any firmware - dies when downloading a new profile with:

Getting model type...OK
Programming modem... Lost communication with modem
Write Parameters... Failed

Any help is greatly appreciated - have I killed the module?


By waltr
The module probable is still good. If you can't get it to re-program using the Reset method with X-CTU then call Digi and open a trouble ticket.
By parki
Thanks waitr - I just got it working again - all of a sudden, it just started working again. I think it might have been clicking "Always Update Firmware".

At any rate, it's back alive!

By waltr
Great news.