SparkFun Forums 

Where electronics enthusiasts find answers.

Discussions on the software and hardware for Atmel's STK standard.
By DarcSystems
#55793
I just pulled this out of the package. I'm using the SparkFun USB Serial programmer, with 0011 and 0012 Arduino IDE software. When I plug the programmer into the pro mini, (with power and TX/RX, or with just power) the red LED on the board stays lit, the green one starts blinking progressively faster, then stays stale for a few seconds, then repeats. I can't write to it. I keep getting this error code:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

What does this mean? I have the correct com port setup. Tried hitting the reset button before programming it, and i set the "Set RTS On Close" option in windows. Nothing seems to be working. All it does it flash that light. I did try removing the jumper on the programmer, and it kept the green light on the controller solid until I reapplied the jumper, then it went right back into its cycle of flashing the light.

Any insight would be appreciated. Thanks.
By DarcSystems
#55839
Nevermind. Got it figured out. Had to solder the reset pins together so it would sync correctly. It worked, that's all that matters.
By dtrichter
#59451
I was having the exact same problem you described above. I, however, have not figured out how to fix the problem.

I am using a Serial USB board:
http://www.sparkfun.com/commerce/produc ... ts_id=8165

An Arduino Mini Pro 5[v]:
http://www.sparkfun.com/commerce/produc ... ts_id=8991

and am trying to program the arduino. Do I need to manually reset? If so when? I have tried 1000 different reset times. You seem to suggest that I need to connect the reset pins together, but I can't seem to find the reset pin on the Serial USB board.

Also, what configuration do the RX and TX pins have to be connected? RX of Serial USB to TX of Arduino? Or should it be the other way around?

Any / All help would be very much appriciated
By dtrichter
#59811
I have spoken with a few other engineers about this issue and have still not found a solution. Any help would be appreciated
By onocentaur
#61060
This is really getting me to too! Just like the above situations, I just can't get it to program, and I'm sure it's to do with the reset. Any help would be gratefully received, before I grind the mini borad into dust :evil:
By onocentaur
#61080
Okay, it's working now. I'm sure I'm not doing anything differently now to what I was before though :roll:
By johnschimmel
#61470
Hi,

I had a similar situation where the stk500_getsync() errors while attempting to program it were occurring. The auto programming reset did not seem to be working and I did the following and it worked.

In the Arduino IDE, upload the code to the Pro Mini device. Immediately after hold the reset switch for a solid second or two and release it.

For some reason this worked for me. Hopefully it helps someone out there.
By onocentaur
#61599
Okay, I had some more problems, but I think I've worked out a definitive solution!

1) You can get the auto-reset to work with this board by soldering a wire into the hole immediatly below the left header pins (when looking at it with the usb port at the bottom - it connects to pin2 on the chip), and connecting this to the hole marked 'GRN' on the arduino mini pro
2) you need to connect the +ve and gnd on the top of the arduino mini pro to the correct pins on the board as shown here
http://arduino.cc/en/Guide/ArduinoMini
('Connecting the Arduino Mini and Mini USB Adapter' - pro has same pinout) EVEN IF you are using an external power source for the board!
By pcrom
#63585
I had the same problems on Vista and also XP using an Sparkfun FT232R USB board on several computers. Now I use an RS-232 to TTL converter and it works great now.

One other thing : Be carefull, there seem to be 2 pinning-variants for the Arduino Pro Mini. BLK and GRN on my arduino is with BLK near the RXD pin, on the photos I always see GRN on that side !!!
By jsprigg
#91705
pcrom wrote:I had the same problems on Vista and also XP using an Sparkfun FT232R USB board on several computers. Now I use an RS-232 to TTL converter and it works great now.

One other thing : Be carefull, there seem to be 2 pinning-variants for the Arduino Pro Mini. BLK and GRN on my arduino is with BLK near the RXD pin, on the photos I always see GRN on that side !!!
Howdy,

I'm doing the same as you - using an RS-232 to TTL converter. I'd rather not use USB for my application.

Might I ask how you managed to get your board to auto reset? Did you connect RTS to the GRN pin?

Cheers,

- Jeff
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]