SparkFun Forums 

Where electronics enthusiasts find answers.

Tips and questions relating to the GPS modules from SFE
By kenshin
#44130
Hi all,

I bought a GM862 evaluation kit which i get from sparkfun for my final year project.I have done everything on GSM and it works well.Now the only thing i left is to transmit the GPS data to my server where the map is display through GPRS.

When i configure all the setting for GPRS,bounch of errors coming out!!!
Here are some command i use;

AT
OK

AT+CSQ
+CSQ=22,0

AT#MONI?
#MONI:MY MAXIS BSIC:03 RXQUAL:0 LAC:2BC1 ID:4DC9 ARFCN:61 PWR:-63DB TA=0
OK

AT#GPRS=1
ERROR

WHy m i getting ERROR??
Is user id and password needed?

AT#USERID=?
#USERID:(50)

AT#PASSW=?
#PASSW:(50)

What is the (50) means??
i called the service provider and the gave me a username n password.SOme how even i type that in also i will still getting ERROR when i type AT#GPRS=1... :(

any1 help pls???
thanks


-KeNshIn-
By maokh
#44137
Have you configured the PDP context, username and password yet?

For example, at&t where i am at required the following configuration:

AT+CGDCONT=1,"IP","WAP.CINGULAR","0.0.0.0",1,1
AT#USERID="WAP@CINGULARGPRS.COM"
AT#PASSW="CINGULAR1"

replace WAP.CINGULAR with your providers APN and the username and password with the one they provided you.

If you already did this or still are having problems, try doing an AT+CREG? and posting the results. You have plenty of signal into the tower, so im not really worried about that.
By kenshin
#44185
These are some details i get from them.But i still having problem :(

5.Change Settings nameto Maxis WAP GPRS
6.Enter Homepage: http://wap.maxis.com.my/wml/index.wml
7.Select Session Mode: Permanent.
8.Select Connection Security: Off
9.Select Data Bearer: GPRS
10.Enter GPRS access point: net
11.Enter IP address: 202.075.133.049
12.Select Authentication type: Normal
13.Select Login type: Automatic
14.Enter User Name: maxis
15.Enter Password : wap


AT
OK

AT+CREG=?
+CREG=(0-2)

OK

AT+CREG=2
OK

AT+CREG?
+CREG: 2,1,"08AF","D143"

AT+CGDCONT=1,"IP","NET","0.0.0.0",1,1
OK

AT#USERID="MAXIS"
OK

AT#PASSWD="WAP"
OK

AT#GPRS=1
ERROR


Why i still getting error???anything wrong with the command??help again....

-KeNshIn-
By DannyDJ
#44225
Hi!I have the same problem with my GM862-GPS with GPRS attach.GSM part wroks fine.I can send SMS, placing calls, but i can't get it to connect to GPRS network. I've setup it up like mentioned above and in "EASY_GPRS Guide" and still getting the same ERROR.

Have you managed to fix the problem?
By maokh
#44241
+CREG: 2,1,"08AF","D143"
You are not registered. this is all in the documentation (software guide) but basically:

0,n - not registered, not looking
1,n - registered
2,n - not registered, but looking
3,n - registration denied
4,n - unknown state
5,n - registered, but roaming

If you are on your home carrier with a valid account, you will see something like this on creg:

state 2
(a few seconds, status LED will flash on and off once a second)
state 1
(led flashes every 5 seconds or so)

If you are stuck in 2 or see 3, either you cannot roam onto any available carrier, or your sim isnt activated or the carrier is denying the imei you are trying to register with. There are a couple of prepaid carriers here in the US that like to lock IMEI's of their special prepaid phones to SIMs. Although, i doubt that would be the case in Malaysia...

Your carrier may also want you to be in a different band? make sure you have #BND selected to the proper range of bands.

Are you using maxis prepaid or contract? The GPRS settings you listed above are for their prepaid network. If its postpaid, you should probably use this:

Operator: - Maxis
GPRS APN: - internet.gprs.maxis
Username: - guest
Password: - guest
DNS: - 202.75.129.101, 10.216.4.21

(ref: http://www.flexispy.com/Mobile%20APN%20 ... 20GPRS.htm )
By kenshin
#44361
I tried this:

AT+CREG=1
OK

AT+CREG?
+CREG: 1,1

is it registered???The LED blinks very 5s.Is everything goes right?

I'm using prepaid here.According to the ref, I type :

AT+CGDCONT=1,"IP","net","0.0.0.0",1,1
OK

AT+USERID="maxis"
OK

AT#PASSW="net"
OK

AT#GPRS=1
ERROR

ERROR again.....why???
I have no idea on what is the band is...by default it was set to 0...
Is it because of the activation of the GPRS caused this?Because in Malaysia in order you wish to have the GPRS services you have to activate it.But in order to activate there is certain setting have to install to the phone(for handphone case).But since this is not a phone, what should i do??
By maokh
#44366
You might want to turn on more debugging, AT+CMEE=2 but i suspect we wont learn much more.

my above data was backwards, its n,1 n,2 etc. 1 means its registered.

i would try to perform the following:

ATD<phone number>;

see if it says OK, and the destination phone rings. When it does, type ATH0 to disconnect the call to avoid charges.

AT+CMEE=2 will give you text based error messages.

In the case of activation, perhaps you should just activate it on a real handset to satisfy whatever requirement, and then move it to the telit.
By kenshin
#44374
yeah!!!finally i get it correct^^

AT#GPRS=1
+IP:10.209.97.155
OK

BUT....there is another problem occur.When i type ATD*99***1#, the Rstrem hang!!WHy??Is not only this command,others command like AT#SKTD=0,80,"www.telit.com",255,80 it will hang as well....How to solve this??Thanks
By DannyDJ
#44388
Hi!Found solution to my problem!I had to activate my GPRS on SIM because it wasn't activated by default. Now it works GPRS connection like mentioned above.

Tnx everybody!

Bye
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]