SparkFun Forums 

Where electronics enthusiasts find answers.

User avatar
By imonthercks
When I plug my Artemis Dev Kit board into my Windows Surface Book laptop the device does not successfully connect and in the Device Manager it shows "Unknown USB Device (Port Reset Failed)". I have tried a variety of different fixes suggested to update drivers and to "uninstall" the USB device from the Device Manager and reboot. Nothing appears to work and I don't find any other cases where users are having this issue, so it may just be an issue with my particular machine. Just wanted to see if there were any suggestions.

Currently running Windows 11 Pro on a Surface Book Model 1832 i7. Have tried both USB-A to USB-C and USB-C to USB-C cables that I know work. Also know that there are not issues with the Artemis Dev Kit board, as I am able to connect it to another windows computer, just not mine.
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum