SparkFun Forums 

Where electronics enthusiasts find answers.

What are we doing right with Artemis? What are we doing wrong? Let us know here!
Dear all,
I very recently checked out the OpenLog Artemis (without IMU) for the first time. The OpenLog Artemis i have came with the firmware version 2.2, which appears to be already the most recent release. I did my first tryout without SD card only watching the output on the terminal screen using RealTerm and the serial monitor of the Arduino IDE.
Still everything made fun and worked, e.g. conecting a BME280 sensor and seeing sensor values in the terminal...
I changed Log Rate to 1 sec and it worked,...

However changing Log Rate to something slower that 1 sec I encountered the problem that it makes the OpenLog freeze and remain unresponsive to any command with the TX LED contantly on.

I checked the release date of the latest firmware 2.2 and it is relatively recently from April, but still I am wondering if I am the first one encountering this problem... because I couldn't find any information or forum entry on this topic !?

Anyway, I re-flashed it with the newest firmware 2.2. No change....
Then I flashed it with v 2.1 and then changing Log Rate to 2 sec. With v2.1 the OpenLog does not freeze but I received every 2 sec the following output:

02:32:57.908 -> SD init failed (second attempt). Is card present? Formatted?
02:32:57.908 -> Please ensure the SD card is formatted correctly using
02:32:58.080 -> ICM-20948 failed to init.
02:32:58.080 -> 07/31/2022,02:32:47.85,0.569,

In v2.1 there was stil the option "3) Configure IMU Logging" and as I have the OpenLog Artemis without IMU, I disabled
"1) Sensor Logging"

So I got at least one error message less:
02:39:15.883 -> SD init failed (second attempt). Is card present? Formatted?
02:39:15.883 -> Please ensure the SD card is formatted correctly using
02:39:15.883 -> 07/31/2022,02:39:05.67,1.695,

OK as I have no SD I also disabled "1) Log to microSD:" but still I received
02:44:18.483 -> SD init failed (second attempt). Is card present? Formatted?
02:44:18.483 -> Please ensure the SD card is formatted correctly using
02:44:18.523 -> 07/31/2022,02:44:08.29,0.582,

Perhaps these observations from firmware v2.1 helps to solve the issue with the freeze in 2.2...

Thank you for your feedback...

I now put an SD card in and OpenLog does not freeze anymore, but I assume that this should not happen even without SD card inside and with Log to microSD: Disabled, right?

Also with my OpenLog without IMU now I receive the following startup message in the terminal window :
IMU offline - or not present
which is clear beacuse it is without IMU

In the log txt in the terminal I receive the message:
17:20:18.303 -> 07/31/2022,17:20:12.10,0.0,
17:20:18.422 -> ICM-20948 failed to init.

But as the firmware 2.2 does not anymore offer the option to disable the IMU, I would have thought that the OpenLog scans availability of the IMU at startup and if not connected, it will not retry to initiate IMU each time...

Is there anything I could do to avoid this?

Thank you for your feedback...
Hi Michael,

I have resolved the issue in v2.3 of the firmware. You can download the new binary from GitHub: ... n/Binaries

It was an interesting issue to solve - caused by calling Serial1.end() when Serial1 had not been begun due to the SD card not being present and so serial logging not being enabled...

Please give v2.3 a try and let me know if you see any more issues.

Best wishes,
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum