SparkFun Forums 

Where electronics enthusiasts find answers.

Discussions about carrier boards have here!
By chaosmose
I am trying to connect a CAN-BUS Shield to my RedBoard Plus to get information from the car via OBD II.
At first, I tried to see if the SparkFun CAN-Bus Arduino Library would work with just the RedBoard Plus and CAN-BUS Shield connected, but first, it does not initialize correctly. The serial monitor shows "Can't init CAN".
I did some light debugging and found that the CANSPEED_500 passed in CanbusClass::init() is not set in the register and mcp2515_read_register() returns zero.
Is the board broken? Can someone please advise?
By chaosmose
Thank you for your response.
I have connected all pins of RedBoard Plus to CAN-BUS Shield as shown in the official Sparkfun Hookup Guilde.
Maybe RedBoard and RedBoard Plus have a different pin arrangement?
User avatar
By YellowDog
Can you provide photos of the top and bottom of your shield and a photo showing it connected to your redboard plus? Maybe we can spot the issue from those.
User avatar
By YellowDog
It should at least initialize, I think you might have a bad solder joint somewhere. You might try retouching your headers and then cleaning the bottom of the board with an old toothbrush and some rubbing alcohol and see if that fixes things.
By chaosmose
Thanks YellowDog and n1ist for your responses.

I redid the soldering, but the result is still the same. I am tired...

D7,D8 on the shield responded and the joystick was fine. Is there an easy way to check which pin is the problem?

By the way, the version of Arduino IDE is 1.8.19. Is it a problem?
 Topic permissions

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum