Tsunami loop stop

Have questions about a SparkFun product or board? This is the place to be.

Moderators: phalanx, TS-Tim

Post Reply
klippard
Posts: 6
Joined: Fri Dec 29, 2017 6:39 am

Tsunami loop stop

Post by klippard » Fri Dec 29, 2017 6:46 am

Short of a system reset, is there a way to stop an automatic looping track once it starts on the Tsunami board?

I've tried setting the trigger to level and holding it low to loop, but the looping is not as smooth that way as it is with automatic looping.

What I am really looking for is a feature to start the loop with an edge trigger, and then the next trigger would stop it, and so on.

klippard
Posts: 6
Joined: Fri Dec 29, 2017 6:39 am

Re: Tsunami loop stop

Post by klippard » Sat Dec 30, 2017 9:01 am

What I am really looking for here is a way to switch between two different looping tracks using a single trigger. I thought I had found a way to do it using the NEXT function with the loop option checked and track range set between 2 tracks, but it is not working. When the trigger is activated, it starts looping the first track, but a subsequent trigger does not cause it to move to the next track and start looping it. Enabling the retrigger option only starts looping the first track over itself. Any ideas would be appreciated. I am running the latest stereo firmware.

robertsonics
Posts: 251
Joined: Fri Mar 24, 2006 7:58 am

Re: Tsunami loop stop

Post by robertsonics » Sat Dec 30, 2017 11:53 am

The answer to your first post is simply to assign a trigger to the "Stop" function, and set the range to the track(s) that you want to stop with that trigger.

For your second post, I'm surprised that the "Next" function isn't doing what you want. Did you set the trigger type to "Edge"? If you uncheck "Loop" does the "Next" function work properly? I won't have a chance to try this for a day or so, but will do so and report back here.

klippard
Posts: 6
Joined: Fri Dec 29, 2017 6:39 am

Re: Tsunami loop stop

Post by klippard » Sat Dec 30, 2017 3:29 pm

Thanks for your reply! The stop function is certainly an option, but I don't want to waste a trigger input on that if I don't have to.

The trigger type is set to "edge" and the function is set to "next".

If I uncheck "loop" the next function does indeed work properly and the board plays the next track when a subsequent trigger is sent.

When "loop" is checked, subsequent triggers seem to be ignored and it continues looping the first track.

robertsonics
Posts: 251
Joined: Fri Mar 24, 2006 7:58 am

Re: Tsunami loop stop

Post by robertsonics » Sat Dec 30, 2017 6:53 pm

It's working fine for me here. I'm using Tsunami firmware v1.04 mono and Tsunami Configurator v0.31. I have 2 short loop wav files as Tracks 1 and 2, and I program trigger 1 to be:

Type = "Edge", Function = "Next, Polyphonic = unchecked, Loop = checked, Track Range = "1" to "2".

Pressing the trigger the first time starts Track 1 and it loops until I press the trigger again, which stops Track 1 and starts looping Track 2. Each subsequent press stops the current track and starts the other one looping.

klippard
Posts: 6
Joined: Fri Dec 29, 2017 6:39 am

Re: Tsunami loop stop

Post by klippard » Sat Dec 30, 2017 7:56 pm

I was using the 1.04 stereo firmware and the Unified 2.0 Configurator. I re-created a new .ini file with the 0.31 configurator, but that still did not work. I did have polyphonic checked, but even unchecking that didn't seem to make any difference.

I then flashed the Tsunami with the mono firmware, converted all my audio files to mono, and now it's working as expected.

I'll probably just stick with the mono firmware, as I really don't need stereo. Thanks for the help!

klippard
Posts: 6
Joined: Fri Dec 29, 2017 6:39 am

Re: Tsunami loop stop

Post by klippard » Sat Dec 30, 2017 9:00 pm

I do wish the polyphonic option worked a bit different in this situation though. Without it, every time I switch between looping tracks, it interrupts normal tracks that may be playing via other triggers. If I turn on the polyphonic option for the looping tracks, both tracks start playing on top of each other rather than switching between tracks.

robertsonics
Posts: 251
Joined: Fri Mar 24, 2006 7:58 am

Re: Tsunami loop stop

Post by robertsonics » Sun Dec 31, 2017 12:12 pm

After thinking about this overnight, I agree with you that it's more useful for triggers to always stop any tracks that they've started, independent of the polyphonic switch. This makes even more sense with Tsunami, where different outputs may be performing unrelated functions. Therefore, if you go to the download page you'll find firmware v1.05, which should now behave as you want.

As a side note, I've tested both the mono and stereo versions successfully, so I don't know why you were having your original problem. The code for this function is identical between the mono and stereo versions. Please try again with v1.05 and let me know if it still doesn't work.

klippard
Posts: 6
Joined: Fri Dec 29, 2017 6:39 am

Re: Tsunami loop stop

Post by klippard » Sun Dec 31, 2017 1:16 pm

Works perfectly with the new mono firmware! Exactly what I needed! Thanks very much for the update! I'll give it a try with the stereo firmware as well and report back.

Post Reply