Noob and ATmega328P bootloader

Support for Bloader and Screamer

Moderator: phalanx

Post Reply
Posts: 2
Joined: Thu Nov 11, 2010 10:04 am

Noob and ATmega328P bootloader

Post by gadman58 » Wed Nov 17, 2010 11:38 am

The short story is I bought two of the ATmega328P IC and was able to program one of them using AVR studio 4 and a AVRISP MKII but not the other one.

I started with the other one, that would not program, on a breadboard using the tutorial on
When it did not work,i thought maybe bad setup.
I pried up the chip on a UNO board I had and plugged it into the UNO board and hooked up the AVRISP still the same answer. Signature does not match on selected device, and when you click on the read signiture or the fuse or lockbits tab sometimes it will enter programming mode but most times it fails.
So I worked my way through the tabs doing mutiple stabs until it would read for that tab. Doing the settings based on what this site said ... tings.html

It failed when trying to write to the flash something about an Flash address error. After that it sticks with the entering programming mode... FAILED!
The LED on the AVRISP is green.

I did try the second chip it had no problems. Put the second chip on my bread board to test the AVRISP connection it worked fine there also.

Is there anything I can do blank it out and try again or do I have just a little brick?

I did have the 6pin wiring backwards when I first plugged in the AVRisp LED stayed red so I trouble shot that problem and the led turned green after repowering back on.
Pin 2 was set as 1 , 3 as 4 and so on.

Thanks for your time

Post Reply