SparkFun Forums 

Where electronics enthusiasts find answers.

Your source for all things Atmel.
By adr1an
Hi all. I'm horribly stuck with this breakout and wonder if anyone can offer some insight.

I have it hooked up to ports 50-53 and INT0 (D2) and am using the code supplied in the thread ... 4359/59#59 over at

As you can see described in that post from myself, I can get video pass-through working fine - I jsut can't generate any OSD and the module seems to loose sync regularly untill you touch near the GND pin on the connector block.

I dont have any pullups or other hardware - just the breakout going to a breadboard going to the pins on the arduino. From what I could makeout from the Schematics, everything is onboard and I should be able to generate an OSD by now!! :)

Any tips or suggestions from anyone that has used this board succesfully would be *massively* appreciated.

Thanks in advance!

By adr1an

I've tried with a 10k resistor tied between reset and V+ as a suggestion from the forums, but still no luck.
By sfe_kav
Hello, my problem my problem is over here.
i write code for spi interaction
ic can display OSD in internal sync or video from input in external sync (OSD I think must be present but not)

The problem - i cant read registers - read_reg allways return 0
OSD does not display in ext. sync (may be problem in black level - i must read default value set bit and next reset bit? but i cant read anything)

when video dark i can see grid on it but without any leters

any ideas?

Arduino 0017
Arduino Duemilanove
Self maded max 7456 brakeout
By sfe_kav
hehehe i change ntsc -> pal and can see OSD in external sync mode
but steel cant read registers
By Liencouer
looking at your code i have not found anything glaringly wrong. your spi for loops go backwards, but you correct that with your bit_mask array being reversed. you have the MSB of the address set when reading from the registers, which is good.

the one thing i would suggest is to try and use the spi hardware instead of bit-banging it. take a look at
By yoppy

I can display OSD.
But, I also can't read the SPI register. Have you solved this problem?

I really need to read the register.

Thank you.