SparkFun Forums 

Where electronics enthusiasts find answers.


Any ideas on the following hookup:

ESP32 Thing plus OPEN PIR
GPOI12 out
ADC2_7 A

The header from the example was changed to

// Hardware Definitions //
#define PIR_AOUT A7 // PIR analog output on A0
#define PIR_DOUT 12 // PIR digital output on D2
#define LED_PIN 13 // LED to illuminate on motion

I get the following dump:

Sketch uses 201396 bytes (15%) of program storage space. Maximum is 1310720 bytes.
Global variables use 13492 bytes (4%) of dynamic memory, leaving 314188 bytes for local variables. Maximum is 327680 bytes. v2.6
Serial port /dev/cu.SLAB_USBtoUART
Chip is ESP32D0WDQ5 (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
MAC: b4:e6:2d:da:c3:c9
Uploading stub...
Running stub...
Stub running...
Changing baud rate to 921600
Configuring flash size...
Warning: Could not auto-detect Flash size (FlashID=0xffffff, SizeID=0xff), defaulting to 4MB
Compressed 8192 bytes to 47...

A fatal error occurred: Timed out waiting for packet content
A fatal error occurred: Timed out waiting for packet content

any ideas?
To TS-Chris there was no code error - I got the exact same thing when had the OPEN PIR connected as shown above but with the simple blink code.

To All; I changed the pin configuration to the following this morning, loaded the code with changing pin names/numbers and it worked.

OPENPIR------------------------------------ESP THING PLUS
A----------------------------------------------14 ADC2_6. GPIO14
OUT------------------------------------------33 ADC1_5. GPIO33
VCC------------------------------------------ 3V3

I found that if I connected anything to pins 12 and 27 (as marked on the "Graphical Datasheet") I got the same error -regardless of the code being loaded (blink, hello world, etc.).
Glad you got it figured out!

IO12 looks like it's looked at by the ESP32 at bootup and connecting something there can interfere with uploading. I found this in the datasheet:
MTDI (GPIO12) should be kept at a low electric level when powering up the module
I wasn't able to find anything that said you might have trouble with GPIO27 but as long as things are working for you now, I'd just stick with that.