SparkFun Forums 

Where electronics enthusiasts find answers.

User avatar
By gagliardo
#202561
Good morning,

i bought 2 of these boards and i am trying to upload some code.

I want to use them without Arduino.

https://www.sparkfun.com/products/13287


I am using Arduino IDE 1.8.5 and the usb-ttl converter in pics attached, found it on Amazon:

https://www.amazon.it/gp/product/B01MR7 ... UTF8&psc=1


I followed the hookup guide:

https://learn.sparkfun.com/tutorials/es ... he-esp8266

I already downloaded and installed the board package and selected "Sparkfun ESP8266 Thing" 115200 baud rate.

Shield switch set on HW.

I connected pins like this:

shield GPIO0 to usb-ttl GND
shield GND to usb-ttl GND
shield 5V to usb-ttl 5V
shield RX to usb-ttl TX
shield TX to usb-ttl RX


The problem is:

"Arduino:1.8.5 (Windows 8.1), Board:"SparkFun ESP8266 Thing, 80 MHz, Flash, Disabled, 512K (no SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 115200"
Lo sketch usa 281080 byte (56%) dello spazio disponibile per i programmi. Il massimo è 499696 byte.
Le variabili globali usano 28008 byte (34%) di memoria dinamica, lasciando altri 53912 byte liberi per le variabili locali. Il massimo è 81920 byte.
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed"


These are the steps i performed in order:

-rebooting IDE and circuitry
-disconnecting and reconnecting pins in different orders
-GPIO0 to GND, reboot, keeping it to GND
-GPIO0 to GND, reboot, disconnecting it
-RST and GPIO0 to GND, reboot, keeping them to GND
-RST and GPIO0 to GND, reboot, disconnecting them
-setting shield on SW and retried as up
-using HW TX/RX pins and SW TX/RX pins and retried as up
-changing board with "Generic ESP8266 Wifi module" and retried as up

i am running out of ideas.

Am i doing something wrong? What can i do more?

Thanks,

Nicola
You do not have the required permissions to view the files attached to this post.
User avatar
By TS-Chris
#202570
Hello, and thanks for posting your question in out new forums!

We've never tried the USB to serial converter you're using but I'm kind of thinking that might be part of your problem. From looking at the pictures of it on Amazon, I think you need a jumper on the converter that connects VCC to 5V on the converter for the RX/TX lines to work correctly. Give that a try and if it's still not working, you may need to go with our FTDI basic breakout. That has been tested and will work.

https://www.sparkfun.com/products/9716
User avatar
By gagliardo
#202583
Thanks for the reply Chris, i just tried as you said and it is not working, always same error messages.

The code upload bar in IDE always swiped at same speed timing, no matter what i changed, like "yes i am uploading..oh it seems there is not serial connection!".

I am definitely suspecting it is my usb serial converter or something related to DTR pin.

If you give me an input for connections i am going to try with an Arduino Uno as a bootloader.