Page 1 of 1

"Fatal Error:Could not find device " Error in MSP-FET and MS

Posted: Mon Jan 23, 2017 8:43 am
by omerd29

I'm using MSP430F5131 and trying to program it by IAR Embedded Workbench while using the MSP-FET debugger.

A short background of the PCB:
After i compiled the code in IAR with not errors found , i connected the MSP-FET to the MSP430 in a Spi-Bi-Wire connection according to the datasheet.
The MSP430 is placed in a PCB which includes 12V input voltage and 2 regulators of 5V and 3.3V . The MSP430 I/O's are connected according to the datasheet (including external pullup resistors and capacitors) along with the Spi-Bi-Wire connections.
I energized the PCB with a 12V supply voltage , connected the MSP-FET's connector to a Header connector on the PCB and the other side connected to the PC by USB.

My problem is :
In the IAR , once i try to download the code into the MSP430 (by clicking the 'Download and Debug' button) it says that it needs a firmware update , so i clicked ok and download the new update , but when it tries to initialize hardware i encounter the error :

"Fatal error: Could not find device (or device not supported)

Session aborted!"

I have tried multiple things in order to find the solution - with no success .

Does the AVcc and AVss needs to be connected even if i dont use any analog options? coz its not connected to anything.

I also tried to download the program to the MSP430 with code composer studio but encounter the same error.

It pops the same error even if i dont connect the MSP-FET to the MCU at all (it is only connected to the PC by a USB cable).

I have connected the MSP-FET to the MCU that way:

- RST/NMI/SBWTDIO of the MCU to TDO/TDI pin 1 of the MSP-FET.
- TEST/SBWTCK of the MCU to TCK pin 7 of the MSP-FET.
- a 3.3V that is supplied from a regulator in the PCB to VCC_TOOL pin 2 of the MSP-FET.
- GND of the PCB to GND pin 9 of the MSP-FET.