SparkFun Forums 

Where electronics enthusiasts find answers.

Discussions on how to get your MSP JTAG programmer up and running.
#116466
Hi,
I have purchased the MSP430-JTAG-TINY, and I am trying to use it with the TI code-composer-studio-4 IDE but can't find any instructions for installation.
In Sparkfun's product page it is written that "MSP430.dll makes it compatible with all existing software which works with TI-USB-FET (emulates TI-USB-FET)", so I was installing the driver, replaced the MSP430.dll and added the rest of olimex's .dll files into Program Files\Texas Instruments\ccs4\ccsv4\DebugServer\drivers, but can't configure ccs4 to work with the debugger because it won't show the "Olimex" option int the debugger list.
Does anyone know a way to make it work?
Thank you,
Yaron
#125352
Hi,

Im using Code Composer 4 and Olimex MSP430-JTAG-TINY-V2. I have followed the instructions on the Olimex Homepage to get the Programmer running with CC4 (copying .dll ...). When I try to start a debug session I always get an error, that a new firmaware for programmer is needed. And if I click onto update button the tool tries to update and after this it ask again for update. I also updated my Programmer using the Olimex programming tool with the newest Firmware (1.04) but it does not help. Has any body experiences with the version 2 debugger? Some colleagues using version 1 without any problems.

Thanks in advance!

Thomas
#166960
Thomas,

Did you ever solve this? I had a similar issue with CCSv5.5, just figured it out. Had to copy the msp430.dll from the Olimex drivers.

The website is https://www.olimex.com/Products/MSP430/ ... rivers.zip, unzip and grab the msp430.DLL, copy to my c:\ti\ccsV5\ccs_base\DebugServer\drivers directory.

Reconfigure the target config (if necessary) to use the "TI MSP430 USB1 (Default)". I renamed the MSP430.DLL that was there to MSP$430.DLL.OLD, just in case.

I am using Windows 7, Professional, 64 bit.

Jake