SparkFun Forums 

Where electronics enthusiasts find answers.

Discussions on how to get your MSP JTAG programmer up and running.
By ogando_jose

The problem is I can't Debug with my USB JTAG TINY on IAR Embebeed Workbench. Here is what I do to install it.

1.- I install MSP430 Workbench.

2.- Then, I copy the 5 DLL's just as described on ...

3.- Then, I install the driver for JTAG TINY, I've tried the ones on that file, and the newer ones ( ...

4.- Finally, I set all the options to USB TI FET, 3.3volts, FET Debugger, but It keeps on telling me "Failed to initialize device, reconnect and please try again"

The PC its a Mac PRO, Xeon, Windows XP, I've tried on other PC's and it works (Its a USB-Dongled Licence)

I've tried to Uninstall everything (Workbench, Drivers, USB dongle drivers) But it does not seem to work. Any suggestions??

EW-MSP430 have Olimex JTAG option, why do you connect as TI USB FET?
By ogando_jose
Well, I got version 3.41, the only options I've got when I select the FET Debugger are Lpt, J-Link, and TI USB FET. I know the correct one is TI USB FET because it works like that on other computers. But as it is a USB Dongle license I want to use it on that computer too.