SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the LEDs and Illumination category should be posted in this forum.
User avatar
By thebenchmark
#204354
Hello everyone

I've been tinkering with some hobby electronics projects at home, mostly succesful. I didn't have an electronics engineering background so often I learn on new topics. I thought that I had enough experience with connecting LED's but I'm having problems with a new project... In this project I have a couple of water valves (both motorized ball valves and solenoids). To indicate which valves are getting power I added an LED with a resistor in parallel to the valves. The valves run on DC12v.

The led burns fine with no solenoid valve in the circuit. When a valve is added the resistor gets very hot and burn up or the led burns up. I have no idea why this happens. I can't understand why the current flow increases to the led as the circuit is parallel. I'm guessing that I'm missing something fundamental to my understanding of electronics. On a more important note how can this be prevented?

The solenoid draws 0.33 A / 4 Watts
The power supply can supply 12V / 5 A, I do expect some voltage drop in the circuit ~ 1 V due to cable length.
Knipsel.PNG
You do not have the required permissions to view the files attached to this post.
User avatar
By TS-Chris
#204356
Hello, and thanks for your post!

The resistor is probably getting hot because you're pushing about .2 watts through it. It may get hot, but shouldn't burn out at that power level.

What could be causing you trouble is inductive kick back from your solenoid when you disconnect power from it. I think what's happening is when you disconnect power, the solenoid is producing a high voltage spike that blows the LED out and shorts it's output. When that happens, the LED is no longer causing a voltage drop and the resistor sees more voltage and that extra voltage causes a larger current to flow through the resistor. That bumps the power up to roughly .26 watts exceeding the power level of your resistor.

So, I have a few suggestions to help with this. The first would be to increase the resistor value a bit to lower the current through it and the LED. Something in the range between 650 to 1000 ohms should work. It will make the LED slightly dimmer but will still likely be plenty bright. That will make the resistor run cooler and the LED last longer.

The second and most important suggestion is to place a flyback diode across the leads of your solenoid. That will 'short out' any high voltage inductive spike that the solenoid coil produces whenever you remove power. With the spike removed, the LED shouldn't burn out. A diode like a 1N4148 should do the trick but a rectifier diode like a 1N4001 or 1N4004 would work as well. Since we're protecting the rest of the circuit from a negative voltage spike, you would connect the diode backwards from what you would normally think. I've modified your drawing to show how the diode would go.
file.png
You do not have the required permissions to view the files attached to this post.