SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the LEDs and Illumination category should be posted in this forum.
I just bought 2 el sequencers (12781) from sparkfun, and I seem to have the same problem with both now: I am not able to upload the arduino code.
I use a 5v FTDI cable to communicate with the boards, I have selected arduino lilypad 328p as board, selected the serial port, made sure the switch on the board is set to FTDI.

The first time I tried to upload code to one of the boards it worked fine, but for some reason now I continue to get this error on both boards:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

The boards gets power (the red LED is on).
On one board the blue status LED is off, then blinks twice when I attempt to start an upload.
On the other it blinks constantly with just a short pause when I start the upload before resuming the constant blinking (I assume this might be the sketch which is already on the board).

I have nothing else connected except the FTDI cable when attempting to program.

I have also attempted to hit the reset button before uploading but that doesn´t make a difference.

Arduino IDE 1.8.9

Hope you can help me figure out why I am having this problem.
Hi hcgiljesen,

The "stk500_recv(): programmer is not responding" error is a tricky one but usually, it means there is a connection issue or you have the wrong port selected. Double check that you are selecting the port the FTDI cable is enumerated on and if that does not fix the issue, can you take a few photos of your EL Sequencers and your connections between them and your FTDI Cable and attach them to your reply?
I am sure I have selected the right port, yes.
Also it worked the first time I uploaded to one of the el sequencers.
Could it be a bootloader problem?
Screen Shot 2019-05-16 at 09.43.09.png
You do not have the required permissions to view the files attached to this post.
Thanks for including those photos. Everything looks fine with your connections. Are you certain your FTDI cable is both 5V Vcc and I/O? I would assume it is since you were able to program the EL Sequencer once but it's worth checking. We carry two 5V FTDI cables. This one is 5V Vcc and I/O but this one has 5V Vcc but 3.3V I/O. Since the EL Sequencer is configured to operate at 5V logic, that might be the issue here.

Double check which FTDI cable you have and if it is the 5V Vcc and I/O version. One way you could check the functionality of that cable is to use it with another board to try and upload code or read serial data from it. Another option would be to try and test the serial pins by jumping RX and TX together, open a serial terminal and test for a loopback from any text you enter in that terminal. If the serial pins are working, you should see whatever you typed into the terminal repeated back.

If you find the FTDI Cable is not working properly and you purchased it from SparkFun, please fill out the form on this page and in the "Why do you want an RMA?" box, fill in a brief description of the issue and link to this topic and we will follow up with further instructions.
it is a FTDI 5v io cable that I am pretty sure I bought from adafruit a long time ago. They sold both a 3.3v and a 5v version and I have both.
I tried with another usb to serial device I had lying around but then I had to do manual reset and couldn´t get that to work either.
Is it possible to use the AVR programmer also for uploading sketches or is it just for burning bootloaders (which I was able to do)?

I will do some more tests, but probably not before after the weekend.
Interesting. You could try using an AVR Programmer to upload code to the EL Sequencer. This section of our Pocket AVR Programmer guide will go over the basics of how to do that.

Like I mentioned previously, I would try using the FTDI cable and other USB to Serial bridge device on another Arduino or testing it with a terminal program and jumper to see if it is working properly. Otherwise, if you are still having issues after further testing, let me know and we can figure something else out.
I did the simple loopback test and it is indeed nothing going on. Eventhough there is no obvious physical damage to my FTDI cable it is obviously not working anymore.
Anyway, I had success uploading using my programmer, so for now this will work.
That is good to hear you identified the source of the problem and are able to work around it for now. Let us know if you run into any other issues or have any other questions about the EL Sequencer and we would be happy to help.
Hi again,

Hmm. The serial lines on the EL Sequencer may not be working properly or are damaged. You could try testing them by uploading code that prints via serial and then, with an FTDI breakout connected to the FTDI header on the EL Sequencer, open up a terminal program or the Arduino Serial Monitor and see if the serial data is sent/received.

If you find the serial pins are not transmitting data properly and this will be inhibitive to your project with these EL Sequencers, we would be happy to help figure something else out here. Assuming you purchased these boards directly from us, you can fill out the form on this page and in the "Why do you want an RMA?" box, fill in a brief description of the issue and link to this forum post and we will follow up with further instructions.