SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Movement & IMU category should be posted in this forum.
#207934
I am using a 9DoF Razor IMU M0 - SEN-14001. When tried to upload a sketch for the first time after getting the product, I get a kind of following error:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 out of 10: not in sync : resp = 0x00 (attached error details in the below attached video link)

I have attached the video of what's happening via the following link https://streamable.com/ja02b

I have searched many forums, hookup guides but not much info on clearing this error, some third party forums says that board may have corrupted bootloader. I am not so sure what is the reason behind this, as IMU - 14001 doesn't have many forum queries or any resources to clear this error. Have seen similar error with Arduino Nano, where they unplug the 5V supply, reset the arduino and try the process again so that this process gets succeeded. Not sure how to proceed with this one.

Can you help me out to resolve this issue. Do let me know if you need more info on anything.

Thanks in advance.
#208020
I was using the native USB and Board : "Arduino Pro/Mini" and Port: "/dev/ttyACM0" without installation of Install Arduino SAMD Boards. After successful installation of the same, could able to see new options like Board: "Sparkfun 9DoF Razor IMU M0" & Port : "/dev/ttyACM0" (Sparkfun 9DoF Razor IMU M0).

Hope this helps someone who face the same issue, follow the Hookup guide for the SAMD board management. Attached an image for the selection.
You do not have the required permissions to view the files attached to this post.