SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Movement & IMU category should be posted in this forum.
#207750
I have a ESP WROOM 32 hooked up via I2C to the LIS3DH, Physically there is no problem, But when compiling my sketch in the Arduino IDE I get a "Error for compiling for board ESP32 Dev Module"

The Error appears wit any sketch with the "SparkFunLIS3DH.h" Library installed while compiling for the ESP32 Dev Kit Board,
The Error will not appear if compiled for another board,
The Error will appear if compiling the unedited example files.

Is there a reason why this lib doesn't work?
#207775
Hi Ejjishin,

I believe this may be an issue with a version push to Arduino regarding the GitHub repository for the library. If you install the library via the Library Manager tool, it installs v1.0.0 of the library which did not have ESP and Teensy compatibility. We are going to get that fixed but in the meantime, you can install the library manually to get around this issue.

The latest version, available for download from the GitHub Repository has no issues with ESP32 boards. You will want to remove the installed library from your Arduino/Libraries folder and then replace it with the .zip library from the GitHub repository. To replace it, you can either manually move the file from wherever it downloaded to or you can use the "Add ZIP Library" tool in Arduino to direct it to the zipped folder.

I hope this helps you get the LIS3DH working with your ESP32 board. If you have any questions about removing/installing the library manually or have any other questions about the LIS3DH breakout, let me know and I would be happy to help.