SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Movement & IMU category should be posted in this forum.
#206932
When I run the F9P Example1_GetPositionAccuracy, the 3D position accuracy prints out only randomly, if at all. My setup is Arduino IDE 1.8.7, iMac with latest Apple OS, Sparkfun ESP32 Thing Plus, RTK2 board. Any thoughts on what's happening? Here's an example serial printout.

Lat: 296101472 Long: -951095912 (degrees * 10^-7) Alt: -15884 (mm) 3D Positional Accuracy: 0mm
Lat: 296101471 Long: -951095913 (degrees * 10^-7) Alt: -15884 (mm) 3D Positional Accuracy: 0mm
Lat: 296101472 Long: -951095912 (degrees * 10^-7) Alt: -15884 (mm) 3D Positional Accuracy: 134mm
Lat: 296101472 Long: -951095912 (degrees * 10^-7) Alt: -15886 (mm) 3D Positional Accuracy: 0mm
Lat: 296101472 Long: -951095912 (degrees * 10^-7) Alt: -15886 (mm) 3D Positional Accuracy: 134mm
Lat: 296101472 Long: -951095912 (degrees * 10^-7) Alt: -15882 (mm) 3D Positional Accuracy: 0mm
Lat: 296101472 Long: -951095912 (degrees * 10^-7) Alt: -15907 (mm) 3D Positional Accuracy: 0mm
Lat: 296101472 Long: -951095912 (degrees * 10^-7) Alt: -15928 (mm) 3D Positional Accuracy: 0mm
Lat: 296101472 Long: -951095911 (degrees * 10^-7) Alt: -15930 (mm) 3D Positional Accuracy: 0mm
Lat: 296101472 Long: -951095910 (degrees * 10^-7) Alt: -15930 (mm) 3D Positional Accuracy: 0mm

Thx.
#207073
Hi dkelly79,

Those 0's are most likely returning because either A) the ZED-F9P doesn't have a solid 3D lock or B) the maxwait timer is expiring and returning 0 by default.

If you can, try connecting the ZED-F9P to your computer and open u-center to check what type of lock you are getting with the ZED-F9P. My guess is either the lock is dipping in and out of 3D maybe due to line-of-sight issues or something else and that is causing the getPositionAccuracy function to return 0. Let me know what type of lock you are seeing in u-center and if it is a hard 3D lock but the example is still printing 0's most of the time we can dig into the issue further.

I will try recreating your issue to see if it is a problem with the example or something else is going on here.