SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Movement & IMU category should be posted in this forum.
#207493
Hello,

I bought the:
SparkFun Qwiic Shield for Arduino

And the:
SparkFun VR IMU Breakout - BNO080 (Qwiic)

I have the combination working using an Uno R3.
When I compile and upload the program to my Arduino Due, the system is not detected:
"BNO080 Read Example
BNO080 not detected at default I2C address. Check your jumpers and the hookup guide. Freezing..."

I'm glad the BNO080 and shield work with the Uno but I need the Due for its processing speed.

Any ideas?

Thanks,
James
#207515
Hi James,

Most likely, the issue you are running into is how the Qwiic Shield is designed. The Qwiic Shield runs the HV I2C lines to A4 and A5 which, on an Uno, correlate to SDA and SCL, respectively. The problem here is on the Due SDA and SCL are on pins 20 and 21 or on the dedicated SDA/SCL pins at the top of the board.

So, in order to use the Qwiic Shield with a Due, you will need to re-route those pins to the correct ones. There are several ways to do this but the easiest option is to just run wires from A4 and A5 on the Qwiic Shield to the labeled SDA and SCL pins. This other post has a couple of other options laid out.

Also, just FYI, a revision to this shield is in the works to fix this problem but there is no firm ETA on when that will be completed. I hope this helps explain the issue and gives you a workaround for the problem.