SparkFun Forums 

Where electronics enthusiasts find answers.

Your source for all things Atmel.
By Wallen
#43788
Has anybody gotten the DX160 to work via SoftwareSerial?

I changed my DX160 to start doing 9600 baud, and everything works coming out of my default TX on the arduino. But for whatever reason, once I switch it over to SoftwareSerial, it doesn't do anything!

Any help would be stupendous.
By dman67
#46136
I got it working on a Freeduino (Arduino clone), but just barely because I'm no programmer by any stretch of the imagination. I used a different library called AFSoftserial that can be downloaded here:

http://www.ladyada.net/make/eshield/download.html

I configured 2 of the Digital ports for the softserial TX/RX port but I'm just using the TX for the serial LCD. Initially with the LCD connected to pin 1 of the Atmega, when I would blow the sketch into it, the code would go out to the LCD too and it would really freak out. Since I've started using the remapped port, the sketch goes in perfectly and the LCD is fat, dumb, happy. I actually hacked the he!! out the example script, but I was able to clear the screen and print "Hello World" @ 57600. Success!!! And it feels good!!! :D

Dman
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]