BootLoader: OLIMEX AVR-MT-128, Anyone succesful with this ??

Your source for all things Atmel.
Locked
Ragooman
Posts: 1
Joined: Tue May 16, 2006 11:32 pm
Location: Pittsburgh,PA
Contact:

BootLoader: OLIMEX AVR-MT-128, Anyone succesful with this ??

Post by Ragooman » Tue May 16, 2006 11:41 pm

Hi,

After purchasing Bascom AVR recently, I've been busy programming the Olimex AVR-MT-128 board with very good success. I normally programmed all my code succesfully with the ISP port. I now want to try installing the bootloader on the Olimex AVR-MT-128 board.

But the bootloader.bas source needs to be modified to support uart2 since the serial port is wired to uart2 on the Olimex board. The serial port checks good when programmed with the simple 'Hello World" test using Uart2 configured. All of my programs for this board currently use uart2 already without any problem.

I updated the source to compile with uart2 and $baud1=19200. Since the Olimex board has only has 1 LED, I had the source code changed to use just one LED.

Then I tried to program using the MCS bootloader with a program that works fine when programmed with the ISP port. The MCS bootloader can't seem to talk over the com port. The LED is blinking constantly. The MCS bootloader window says RESET constanty. The dialog windows repeats the same thing over:
Log Window
Open COM
Sending Init byte
Loader returned : 0

Then I use the Terminal emulator, and I upload the same program which has been tested good when programmed with the ISP port. The Terminal emulator shows that something is downloading by displaying the progress bar in the lower right corner. But when it's finished, I get nothing after I press reset icon on the IDE(the ISP cable is still connected because the Olimex board doesn't have a Reset button)).

the bootloader source can be found at the link below in hopes that you might know what is missing in this.
http://www.pghrobotics.org/projects/rob ... mt-128.bas

thanks,
Dan
Home: http://ragooman.home.comcast.net/
Robot Club: http://www.pghrobotics.org/

Locked

Return to “Code”