FM Receiver Breakout with ATmega168

Your source for all things Atmel.

Moderator: phalanx

Post Reply
dreiercarr
Posts: 5
Joined: Sun Dec 13, 2009 9:10 pm

FM Receiver Breakout with ATmega168

Post by dreiercarr » Fri Feb 12, 2010 9:46 pm

I am pretty new to AVRs and just got my feet on the ground with the Sparkfun tutorial with the ATmega 168.

I also picked up a FM Radio Breakout Board and an OpAmp breakout.

Sparkfun has some demo code for the FM receiver that I successfully loaded onto the AVR. I didn't get any errors when I made the code or programmed. I got the UART on the 168 working from the tutorial but am getting squat from the demo code. I set the AVR so I think it should be running at 8MHz (avrdude -p m168 -P lpt1 -c stk200 -U lfuse:w:0xE2:m) and I'm pretty sure my serial connection is hooked up correctly on pins 2 and 3. For the sake of getting the code running, I disconnected the FM breakout board and the OpAmp and am running at the normal 5V, although I'm going to try to run everything at 3.3V since the breakout boards can't take 5.

Any help on what I'm missing to get the code to run? There isn't a ton of documentation that I could find, but I think I should be seeing a menu display over the UART on reset. The code is on the Sparkfun page for the FM Breakout board.

Thanks a ton!

maokh
Posts: 143
Joined: Sat May 21, 2005 7:49 pm
Contact:

Post by maokh » Wed Feb 24, 2010 2:17 am

Are you making use of the CS line? SPI requires chip selects before something can talk to it, perhaps its just expecting that. connect CS to a third digital pin, and make it go high?

Also, make sure the module and the 168 have a common ground between them, thats always a easy mistake to make.

Post Reply