Serial Graphic LCD Backpack Issue

Your source for all things Atmel.

Moderator: phalanx

Post Reply
ajk265
Posts: 5
Joined: Mon Feb 26, 2007 9:13 am
Contact:

Serial Graphic LCD Backpack Issue

Post by ajk265 » Sat Nov 21, 2009 11:56 am

So, I am having issues getting my display working. My hardware is an ATMega168 connected to Sparkfun's 128x64 Graphic LCD Screen through the Serial Graphic LCD Backpack.

I used the code that was in the serial backpack, but was having issues with it printing random characters. I am using the internal 8MHz, which is probably part of my issue, since it has large error when using a baud rate of 115,200.

Because of this, I connected the serial port directly to the screen so that I can use the command in the data sheet to set the baud rate to something that is actually supported well at that frequency.

From the serial port, I connect the grounds together, connected the rx from the backpack to the tx of the port. I set it to 115,200 baud, 8 data bits, no parity and 1 stop bit. The flow control had to be set to Xon/Xoff without a hardware handshake to print characters at all.

However, none of the character print what is expected. When I press a capital A, it prints an underscore. Also, to run the demo code, you're supposed to print '|' and then <control>d, but this doesn't do anything but print random characters on the screen.

Any ideas of what I'm doing wrong (most likely a stupid mistake or two)? If you need more info from me, please let me know. Thanks for your help in advance!

Post Reply