Page 1 of 1

AVR-MT-128 Serial Comm to PC not working

Posted: Sat Jul 23, 2005 9:37 pm
by twoba
I am running the example code that comes with the AVR-MT-128 but I can't get the serial connection to my PC to work right. When I hookup a com port on my PC to the AVR-MT-128 DB9 I type on my PC keyboard and see strange characters on the AVR-MT-128 display. Likewise when I click the B5 button, the LCD says "sending to RS232" but my terminal app on my PC shows strange non-alphanumeric characters. I am sure that there is an easy answer to this. Does anyone know what the correct serial port settings are for a terminal emulator to talk to the AVR-MT-128?
By the way, I have tried Hyperterminal, the terminal emulator that comes with Bascom and MTTTY using all baud rates and different handshake, RTS settings but they all show unreadable characters.

Posted: Sun Jul 24, 2005 6:37 am
by murphyr
Confirm that your AVR-MT-128 is using the clock source that you think it is using (confirm by reading fuses or write a blinky program to blink a led at 1 Hz)

Usually you need 8 bit, no parity, 1 stop bit, no flow control, probably at 9600 (but you need to confirm this in the code)

Posted: Mon Jul 25, 2005 5:43 am
by twoba
Thanks, I tried setting the fuses as suggested on this page: This worked once, but after that, my PonyProg tells me "Device missing or unknown device (-24)" when I tried to tweak the fuses again. Is there a way to reset the fuses so the PonyProg can read and write them again?
By the way, before I had the fuse problem I wrote a led blinky program and it blinked pretty close to every second.

Posted: Tue Jul 26, 2005 6:58 pm
by twoba
Ok, I think I accidentally screwed up my avr-mt-128 board. When I read the Configuration and Security Bits, PonyProg tells me that all of them are programmed, including the lock bits. One website I found said to erase the flash, but the erase function fails with the same "Device missing or unknown device (-24)" message. Anyone have a suggestion on how I can reset or unprogram the lock/security bits and fuses?

Posted: Tue Jul 26, 2005 7:53 pm
by murphyr
It sounds like you may have set the clock fuses incorrectly. Check out, search the forums for “dead AVRâ€