SparkFun Forums 

Where electronics enthusiasts find answers.

Questions &/or issues related to products in the Flex / Force category should be posted in this forum. includes Force Sensitive Resistors, Load Cells & Amplifiers, Pressure Sensors, etc
User avatar
By stefanini
I am new to Openscale and Loadcells .. pardon me on my question.

I am getting readings such as 156462,-59.69,lbs,19.37,0, when I have connected Openscale and one load cell. Opensclae is connected to Raspebrry pi via USB, and I am seeing this reading.

I am not able to decipher this data payload. Please help me understanding this reading what each represents.

Second question is - if I need to connect 4 load cells, will all that go into the same connection and how the readings come out
User avatar
By TS-Chris
Hello, and thanks for posting your question in the forums!
I am getting readings such as 156462,-59.69,lbs,19.37,0, when I have connected Openscale and one load cell.
OK, let me decode that for you. By default not every field is turned on and the format you're seeing is the default. The format when every field is turned on is:
timestamp , calibrated_reading , units , raw_reading , local_temperature , remote_temperature

In your case, you have the timestamp, calibrated reading, units set to lbs, local temp and remote temperature turned on.

This is a time stamp that indicates the time in ms since the OpenScale was powered on


This is the calibrated reading in pounds or kilograms.

You can change this field to say lbs if you've calibrated the device in pounds, or kgs if you've calibrated the device in kilograms


This is the local temperature of the OpenScale board.


This is the reading from an optional DS18B20 temperature sensor that you can attache to the OpenScale board. In your case it looks like you don't have a sensor attached and so the board is give you a 0 reading.

You can actually turn on and off some of the data fields if you wish. The following fields can be turned off.
  • timestamp
  • raw_reading
  • local_temperature
  • remote_temperature
Turning these of just make them not print. For example, if you turned all of them off, you'd only see the following output:

There's a menu you can access to change various settings in the OpenScale and turn the various fields on and off. Sending the letter x will get you into that menu and the menu options should be fairly straight forward in what they do.

You might also want to check out the Hookup Guide for the OpenScale. That should clear up any other questions you have about the operation of the board.
if I need to connect 4 load cells, will all that go into the same connection and how the readings come out
As to connecting load cells, you can connect 1 four wire load cell to the screw terminals on the board. We have pads on the side of the board for connecting 4 three wire load sensors. If you're connecting load sensors, you must connect all four and the wiring is as follows:
  • - = black
  • + = white
  • C = red
It is possible to connect more than one four wire load cell to the board, but you need a summing box to do that. Unfortunately we don't carry summing boxes, but a google search should turn up some options for you. We have had customers connect their load cells in parallel without a summing box successfully, but we've not tested this configuration and can't say for sure if it's accurate. Connecting more than one load cell or load sensor won't change the output, you still receive a single weight for the combination of all the sensors.
User avatar
By stefanini
You indicated on connecting 4 load cells ... "Connecting more than one load cell or load sensor won't change the output, you still receive a single weight for the combination of all the sensors."

Does that mean, there is no need to do this and can be accomplished by just using one load cell, say placed in the center of a shelf rack for example and it will be an accurate reading?

Also, you indicated that there are pads on the side of the board connecting .. what are UL/LL and UR/RR ... do I connect there and does it need a combinator?
User avatar
By stefanini
Question .. since I have connected 4 load cells (all greens with green, reds with red etc..) and connected to the respective terminals - am I getting one single reading from all the load cells? For example, when I place 9 units each weighing 6 lbs, I am getting a reading as 240 lbs. Not sure how? I was expecting weight around 54 lbs (9 units x 6 lbs = 54 lbs). Similarly, when I remove 1 unit, I expect weight to be 8x6=48 lbs

What am I doing wrong? Is there a connection problem or something I am missing here?
User avatar
By stefanini
I am following the calibration instructions. I am using the serial monitoring tool within IDE. I did connect the board to monitor the weight
I sent 1 to tear to zero
I placed the known weight, for example 24 lbs and let it stabilize
Sent command 2 to calibrate for know weight. At this point I am not sure how to send a key after inputting 24
so I typed 24 at he menu prompt and clicked send ...

nothing happens at this point .. currently it is showing 118 lbs as the current reading
User avatar
By TS-Chris
OK, lets try this:
  1. Make sure the Serial monitor is set to 9600 baud and 'No line ending'.
  2. Take the weight off the scale.
  3. Type an x into the send box and click send to access the menu.
  4. Type a 1 into the send box and click send to tare the scale.
  5. Wait a few seconds for the scale to tare.
  6. Now type a 2 into the send box and click send.
  7. Place your weight onto the scale.
  8. Type any letter in the send box and click send.
  9. Type 24.00000000000 for 24lbs. and click send. (You need 14 characters total including the decimal point to fill the array for weight.)
  10. Type an x in the send box and click send to exit the menu.
At this point you should be calibrated and ready to go and weights should be printing. If you're still having trouble, please snap some photos showing your setup, zip them up into a single file and attach those to a reply and we will look to see if there is something wrong with your hardware.
User avatar
By stefanini
Speaking of hardware ... earlier I was able to see the menu through IDE .. and for some reason firmware upgrade or something it is not showing at all. Is there a way to get back to the original shipped firmware and if so how to go back to that? When I connect the board I do not see data streams coming through at all
User avatar
By TS-Chris
Not sure what's going on there.

Have you actually uploaded new code to the Openscale board? Unless you've uploaded new code in the Arduino IDE, the firmware should not have changed at all on your board.

One thing you might try is factory resetting the board and seeing if that brings things back to normal. These directions from the hookup guide will help resetting the board back to factory defaults and would be the first thing to try.
If you get OpenScale into an unknown configuration you can reset the board to safe defaults. Power down OpenScale, attach a jumper from RX to GND on the serial connector, then power up OpenScale. You should see the status LED blink rapidly for two seconds then at 1Hz. This indicates OpenScale has been reset to 9600bps. This will also reset all system settings to safe defaults.
If you accidentally uploaded some other code to the board, this section of the hookup guide will walk you through restoring the latest version of the firmware to the board. I recommend using the latest version since it includes bug fixes and makes the OpenLog easier to calibrate.

One last thing to try would be to not use the serial monitor in the Arduino IDE to talk to the board and use a terminal program like Tera Term instead. Tera Term lets you send data to the OpenScale one character at a time in real time rather than a string of characters all at once. That helps make some of the menu options a little easier to use. You can get Tera Term at this link. More information about Tera Term can be found here.

If you're on a Mac, try Cool Term. You can grab Cool Term here and we have more information about Cool Term on this page.
User avatar
By stefanini
I tried your instruction to reset to factory default. It did not work. Also, tried to to get the latest version as well. Following the instruction, I fail to verify. Errors out saying no openwire.h.

May be I am doing something totally wrong. Is there a way you will be able to call me or email me to help me out. Let me know, I can setup a skype call if you email me your email address
User avatar
By stefanini
info on updating the firmware says .. OpenScale ships with the Optiboot serial bootloader (115200bps, 16MHz) ..
Is there a way to burn this onto the board and if so where I could get that and steps to do it?

I am bit last, need help
User avatar
By stefanini
The board seems to be a defective one. How can I return this for an exchange. How do I initiate the process for returning and get an exchange or the same. I have heard an RMA process to be started.
Please let me know how it should be done
User avatar
By TS-Chris
If you purchased this directly from us, please fill out the form on the right hand side of this page to start the return/RMA process. Don't forget to enter your SparkFun order or invoice number in the form and if you know the part number, enter that as well. In the Why do you want an RMA? section, enter the URL for this forum post so the returns processor can see what troubleshooting steps have been taken.

If you purchased the part from a distributor of ours, you will need to contact them for a replacement.