Unable to run Atmega32u4 at 3.3v

Discussions on the software and hardware for Atmel's STK standard.

Moderator: phalanx

Post Reply
nav999
Posts: 1
Joined: Thu Apr 28, 2016 8:30 am

Unable to run Atmega32u4 at 3.3v

Post by nav999 » Thu Apr 28, 2016 8:38 am

I am using an atmega32u4 microcontroller in my project. The 32u4 is connected in my project in a same way as that of atmega32u4 breakout board from sparkfun. In my project the 32U4 is connected to 5v and 16mhz crystal oscillator and it works fine and gets detected by my PC. But my project requires to be run at 3.3v. when i connect it to 3.3v at 16mhz my PC shows 'USB device not recognized. even at 12Mhz and 8Mhz at 3.3v is shows the same error . Please help me on getting the atmega32u4 running at 3.3v by any means possible.

skimask
Support Volunteer
Posts: 1244
Joined: Sun Nov 09, 2008 2:11 am
Location: Minot, N.D.

Re: Unable to run Atmega32u4 at 3.3v

Post by skimask » Thu Apr 28, 2016 2:01 pm

Can your oscillator run at 3.3v?
I ignore "one post wonders".

stevech
Support Volunteer
Posts: 2907
Joined: Sat Jun 05, 2004 8:51 pm
Location: USA, California

Re: Unable to run Atmega32u4 at 3.3v

Post by stevech » Sat Apr 30, 2016 10:38 pm

nav999 wrote:I am using an atmega32u4 microcontroller in my project. The 32u4 is connected in my project in a same way as that of atmega32u4 breakout board from sparkfun. In my project the 32U4 is connected to 5v and 16mhz crystal oscillator and it works fine and gets detected by my PC. But my project requires to be run at 3.3v. when i connect it to 3.3v at 16mhz my PC shows 'USB device not recognized. even at 12Mhz and 8Mhz at 3.3v is shows the same error . Please help me on getting the atmega32u4 running at 3.3v by any means possible.
What oscillator frequency does the code running on the 32U4 require for the USB to work correctly?
Does the 32U4 spec sheet say it has a maximum clock frequency when used at 3.3V rather than 5V?

Post Reply