SparkFun Forums 

Where electronics enthusiasts find answers.

Discussions on the software and hardware for Atmel's STK standard.
By noobay
#184857
Hello, I'm new here :)
So I have my Olimex USB(https://www.sparkfun.com/products/8702) programmer that is connected to an Atmega8-16pu via a 6 pin connector without an external oscillator, and with external power to the circuit from a wall-plugged ~120VAC to 5VDC USB converter.
it worked completely fine using AtmelStudio 6.2, i managed to program it and modify the circuit until(after a day or two of successful operation) I suddenly saw the message -
"Unable to enter programming mode.
Failed to enter programming mode. ispEnterProgMode: Error status received: Got 0x80, expected 0x00 (Command timed out)"

Steps I took to fix the problem were:
*I removed all the connections to the MCU except for the programmer's,
*I double checked the pins
*Replaced the chip with another atmega8-16pu
*reflashed the Programmer's firmware
*I went to AVR freaks, I was told to remove the programmer's driver from my PC, restart and replug+reinstall the driver,
so I did, it didn't work.

I am lost :(

What might be the cause of it? how can I check for the cause?
Thank you in advance! :geek:
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]