SparkFun Forums 

Where electronics enthusiasts find answers.

Discussions on the software and hardware for Atmel's STK standard.
By planecrazy29
#170450
I recently purchased a USBASP programmer. I have spent (too) many hours trying to get it to work under Windows 8.1 and have given up at this point. I cannot used unsigned drivers on my laptop since windows 8.1 crashes every time I try to get to the startup options. What are my options here? Do just need to bit the bullet and get a dragon?
By planecrazy29
#170499
I've spent hours upon hours searching google. It appears that even the mkii has some issues with Windows 8.1. My current solution is to use an arduino as an ISP. I'm just bootloading 328p-au chips in-circuit so it works even though it's a bunch of hoops.
User avatar
By Ross Robotics
#170506
I believe I had the same trouble with my Windows 7 x64 with unsigned drivers, but it's been so long ago, I forgot what I did to bypass the issue. I know there is a work around, you are just going to have to Google for it like i did. I use an MKII..
By davidpulvermacher
#186977
Seems that this is a real pain...
I flashed my TG9X some time ago using the Sparkfun USBasp programmer with no problem on XP.
Now trying to read the eeprom from the Tx I get the dreaded “avrdude: error:could not find usb device 'usbasp' with vid=0x16c0 ... etc.

I wonder whether there is any further resolution to this problem?
I tried the various method described on the 'net, related to driver signings and proper installtion of drivers, but to no avail.
Any advice would be more than welcome!
Best DP.