Reload Arduinio Pro Mini Boot Lader

A place to hang out and chat with other like minded tinkerers

Moderator: phalanx

Post Reply
rdiederich
Posts: 1
Joined: Mon Mar 02, 2015 7:38 pm

Reload Arduinio Pro Mini Boot Lader

Post by rdiederich » Mon Mar 02, 2015 7:46 pm

I have spent a lot of time, multiple days, trying to fix a failure to load a sketch into a Arduino Pro Mini through the Sparkfun FTDI basic board. This use to work just fine and with no changes it started failing. After changing cable, a new FTDI board, changing com ports, updating to the latest version of the EDI I finally tried a new Arduino Pro 5v. 386 board and I was able to load with no problem. Going back to the previous ProMini it still fails. So from that I surmised the problem was in the ProMini board and that most likely the bootloader was defective. I have tried reloading the bootloader using the “Burn Bootloader” command from the Tools menu.

However that does not work I get the following log file
------------------------------------------------------
Arduino: 1.6.0 (Windows 7), Board: "Arduino Pro or Pro Mini, ATmega328 (5V, 16 MHz)"

C:\Program Files (x86)\Arduino/hardware/tools/avr/bin/avrdude -CC:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -cstk500v2 -Pusb -e -Ulock:w:0x3F:m -Uefuse:w:0x05:m -Uhfuse:w:0xDA:m -Ulfuse:w:0xFF:m

avrdude: Version 6.0.1, compiled on Apr 3 2014 at 23:12:16
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf"

Using Port : usb
Using Programmer : stk500v2
avrdude: usbdev_open(): did not find any USB device "usb"
Error while burning bootloader.


---- I am connected to Com10 on my laptop and do not understand why the boot loader is asking for a USB port that does not exit. Can you provide me with some information on how to reload the boot loader on the proMini.

Arduino: 1.6.0 (Windows 7), Board: "Arduino Pro or Pro Mini, ATmega328 (5V, 16 MHz)"

Post Reply