SparkFun Forums 

Where electronics enthusiasts find answers.

General MicroView Support area - You have questions, find your answers here.

Moderators: marcus@geekammo, Help@GeekAmmo

By Baldrick100
Just after a bit of help.

I'm using the Microview in the USB Microview programmer - it fired up with the demo when first plugged in.

The problem is I get the following error message in the Arduino IDE 1.6.2:

Error Compiling:
Arduino: 1.6.2 (Windows 7), Board: "Arduino Uno"
Build options changed, rebuilding all
MicroViewDemo.ino:18:23: fatal error: MicroView.h: No such file or directory

compilation terminated.

Error compiling.

I have followed the IDE installation instructions, the FTDI Driver instructions, set the board to Arduino Uno and identified the Com port using Device manager (Windows 7)

Other IDE settings: Programmer = AVRISP MKII (not set by me) and baud rate 115200 (win com port set to same) Tried 9600 baud also)

The Time and Microview-master libraries are showing under sketchbook and examples.

I can't seem to get anything to compile or upload. Tried HelloWorld sketch - same result.

I get nothing on the Microview now. USB programmer has a constatnt LED.

Hope someone can help. Thanks
By scotta
The Time and MicroView libraries should be in a folder named libraries in your sketchbook folder. The MicroView library files should be in folder MicroView under libraries. The Time library files should be in folder Time under libraries.

Here's the organisation and contents of my libraries (on a Linux system):
Code: Select all
└── libraries
    ├── MicroView
    │   ├── 7segment.h
    │   ├── font5x7.h
    │   ├── font8x16.h
    │   ├── fontlargenumber.h
    │   ├── gpl-3.0.txt
    │   ├── keywords.txt
    │   ├── MicroView.cpp
    │   ├── MicroView.h
    │   ├──
    │   ├── space01.h
    │   ├── space02.h
    │   └── space03.h
    └── Time
        ├── DateStrings.cpp
        ├── keywords.txt
        ├── Readme.txt
        ├── Time.cpp
        └── Time.h
By Baldrick100
Thank you Scotta.

That was on the money and it all works sweet as now.

I was following the tutorial that mentions placing the libraries and renaming but does not say what was renamed or why plus the unzipped file structure for the time and microview libraries if not altered don't help a newby like me.

I just ended up snotrning the tree structure for the libraries and put them manualy under the Arduino library folder and it found them.

Appreciate the help.

Kind Regards,

By bjbiver
I was having the same problem and when I checked, my .cpp file was in the folder "C:\Users\%username%\Documents\Arduino\libraries\MicroView-master\Libraries\SparkFun_Microview". I simply copied (not cut) all of the files in that folder to the "C:\Users\%username%\Documents\Arduino\libraries\MicroView-master" folder, restarted the application, and I was able to upload.
By Help@GeekAmmo
Thanks Scott.

Hi Baldrick100 & bjbiver,
I kind of suspect the instructions here ... -microview
was a bit unclear leading to the library not installed in the correct location. In the instructions, the library was stored in SparkFun_Microview but in the image and text, users were asked to browse to MicroView folder.

If you follow this
at section "Install MicroView Library", you should be able to get it right.

long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]