[phpBB Debug] PHP Warning: in file /mnt/forum-shared/ext/sitesplat/BBCore/event/listener.php on line 70: in_array() expects parameter 2 to be array, boolean given
data.sparkfun.com - SparkFun Electronics

SparkFun Forums 

Where electronics enthusiasts find answers.

Everything pertaining to the data.sparkfun.com service, the phant project which powers it, and user projects which talk to the service.
By LukasCZE
#194505
Hello,

I am runnig my Thermometer few weeks on Phant at data.sporkfun.com but I am having problems since yesterday. Do you also find service sometimes offline? or overloaded, idk.

Not sure if there is a problem on my side or not.

For example https://data.sparkfun.com/streams/6JZbNolApzF4om2l9yYK doesnt work. Its example stream from https://learn.sparkfun.com/tutorials/pu ... net-shield .

I get:
-------
502 Bad Gateway
The server returned an invalid or incomplete response.
-------------

Denote that now I am not at home but in library.

Thx

Lukas
By LukasCZE
#194530
but still... sometimes i obtain

HTTP/1.0 502 Bad Gateway
Cache-Control: no-cache
Connection: close
Content-Type: text/html

<html><body><h1>502 Bad Gateway</h1>
The server returned an invalid or incomplete response.
</body></html>

denote that X-Rate-Limit-Remaining is 297 right beforehand

do you experience this issue as well?
User avatar
By darrellg
#194531
LukasCZE wrote:do you experience this issue as well?
I don't use this service.
By LukasCZE
#194537
so maybe someone else...?

sometimes i obtain
Code: Select all
HTTP/1.1 200 OK
Access-Control-Allow-Origin: *
Access-Control-Allow-Methods: GET,POST,DELETE
Access-Control-Allow-Headers: X-Requested-With, Phant-Private-Key
Content-Type: text/plain
X-Rate-Limit-Limit: 300
X-Rate-Limit-Remaining: 296
X-Rate-Limit-Reset: 1493205040.307
Date: Wed, 26 Apr 2017 11:01:13 GMT
Connection: close
Transfer-Encoding: chunked
Set-Cookie: SERVERID=; Expires=Thu, 01-Jan-1970 00:00:01 GMT; path=/
Cache-control: private
but sometime
Code: Select all
HTTP/1.0 502 Bad Gateway
Cache-Control: no-cache
Connection: close
Content-Type: text/html

<html><body><h1>502 Bad Gateway</h1>
The server returned an invalid or incomplete response.
</body></html>
By mage2
#194858
just started using the service today, or trying to.
I am also getting the gateway error. After a few tries it seems to get through.
also having a hard time getting analog.io to import a stream from data.sparkfun.com
will open a new thread on that though