SparkFun Forums 

Where electronics enthusiasts find answers.

Everything pertaining to the service, the phant project which powers it, and user projects which talk to the service.
By ZenEE
I have been using a Sparkfun Thing Dev board to post data to Phant.

I started by making a stream and posting the to No problems here.

I installed a Phant server on a private computer and posted the data to there. Also, no problem.

However, I restarted my private computer and didn't realize that the Phant stream would not persist after the server/computer was restarted. Since my old stream was destroyed, I created a new one. I inserted the new public and private keys into my code and loaded it into my Thing Dev board. However, I wasn't seeing any data being posted to my new Phant stream.

I tried switching back to and my Thing Dev board posted data to there without issue. That indicates the problem is with my Phant sever.

I verified the host name of the private Phant server in my code and it is correct. I have tried both the straight IP address on my network and a DDNS server that I set up through Both the IP address and DDNS worked before, but now neither of them work. The private and public key seem to be right. The port I am using is 8080.

The telling part is that the server says no data has been posted to the stream, but my Thing Dev board says that it connects to my wifi and that the post was successful. Bottom line: What is wrong with my private Phant sever where my Thing Dev board thinks the post was successful, but Phant has nothing in the stream?